Ask Your Question
1

How to kill master process 'rosout'? (will always respawn)

asked 2011-03-08 02:23:07 -0600

Julius gravatar image

I used 'roscore &' to launch the ROS master server in a shell script. That might not have been a good idea. After invoking this script I failed to kill process rosout as it always respawns with a different pid. It looks like a watchdog process but I couldn't find one so far. Is there any possibility to kill rosout without having to restart my system?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
2

answered 2011-03-08 03:12:18 -0600

dornhege gravatar image

It's a python script. So killall python will work.

If you have other python stuff running: ps aux|grep roscore and kill the python process with roscore in the name

edit flag offensive delete link more

Comments

I strongly recommend against running "killall python". That will kill every python process on your system.
kwc gravatar imagekwc ( 2011-03-08 03:13:12 -0600 )edit
Yes, you're totally right that my suggestion to use 'killall python' is nasty (I pointed this out, too). I removed my answer to avoid any further confusion and let quality rule over quantity.
Julius gravatar imageJulius ( 2011-03-08 03:32:25 -0600 )edit

killall python no longer works. Is there an elegant solution to this problem?

McMurdo gravatar imageMcMurdo ( 2014-04-27 22:23:59 -0600 )edit
3

answered 2011-03-08 03:06:48 -0600

kwc gravatar image

roscore itself is set to always keep respawning rosout. You have to kill the roscore process in order to resolve this.

edit flag offensive delete link more

Comments

There is no such process as 'roscore', at least not on my Ubuntu Maverick + ROS Diamondback. I should have stated the version information earlier.
Julius gravatar imageJulius ( 2011-03-08 03:25:03 -0600 )edit
1
The roscore process is a python one. `ps aux | grep roscore` should get you the pid of the job.
tfoote gravatar imagetfoote ( 2011-03-08 03:27:28 -0600 )edit
0

answered 2011-03-08 03:04:33 -0600

dornhege gravatar image

perhaps: killall roscore

edit flag offensive delete link more

Comments

I've tried your suggestion, but unfortunately to no avail since there isn't any process called 'roscore' on my system. Note that I've already tried to kill 'rosout' but to no avail either.
Julius gravatar imageJulius ( 2011-03-08 03:18:27 -0600 )edit
0

answered 2016-09-05 00:16:06 -0600

sunking gravatar image

I had the same problem of a rosout process that keeps respawning. The problem is that roscore is running, but finding it takes some effort. 'ps -e' doesn't show it, but if you do 'ps aux' you'll see it (along with a couple of other roscore related processes along for the ride). You need to kill them all

edit flag offensive delete link more
0

answered 2016-09-06 02:32:19 -0600

Humpelstilzchen gravatar image

For the future edit /opt/ros/indigo/etc/ros/roscore.xml (change the path according to your ros distribution) and set respawn to false for rosout:

<node pkg="rosout" type="rosout" name="rosout" respawn="false"/>

This will only work after a roscore restart.

edit flag offensive delete link more

Comments

1

I think it would be a good idea to add a big warning here that if you do this, and rosout ever crashes, you'll lose the logging output from all of the nodes in the node graph. There is a reason rosout is set to respawn automatically.

gvdhoorn gravatar imagegvdhoorn ( 2016-09-06 02:46:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-03-08 02:23:07 -0600

Seen: 3,663 times

Last updated: Sep 06 '16