Ask Your Question
1

pioneer 3dx simulation using rviz and stage

asked 2011-03-04 07:57:45 -0600

vprasad gravatar image

Hi, I installed ROS on ubuntu 10.10 and I'm trying to simulate a pioneer robot on rviz. I have the usc p2os package and I'm trying to use the pioneer3dx.urdf for the robot simulation. The robot is recognised by rviz but the left, right wheels and hubcaps are not being recognised. I'm getting "no transform from [/...] to [/odom] error. Any help would be greatly appreciated.

thanks, Vinay

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-03-07 05:08:23 -0600

hersh gravatar image

RViz listens for TF messages, by default on topic /tf. That is the only way it knows where each part of the robot is relative to other parts of the robot.

On my (simulated) system, /tf is published by nodes amcl, robot_pose_ekf, robot_state_publisher, and gazebo. Perhaps you need to run more nodes to fill in the missing TF frames.

If nothing is filling in the /odom frame, you can try setting the "fixed frame" in RViz to /map or /base_footprint. For that matter, in my system I don't have a frame called /odom, I only have /odom_combined. Maybe that is the problem?

edit flag offensive delete link more
0

answered 2011-09-06 08:58:54 -0600

updated 2011-09-07 04:52:20 -0600

I've come across with exactly the same problem a couple of hours ago, and, strangely, removing and re-checking out the p2os from the repository solved the problem as it is explained here.

Besides, be careful about the /use_sim_time parameter. If you run gazebo launcher(pioneer3dx.gazebo.launch) first, -since it sets this parameter to "true" via empty_world.launch- launching the pioneer3dx_urdf.launch after will not yield a proper visualization. Either set this parameter to false by "rosparam set" or add

<param name="/use_sim_time" value="false" />

to your custom launch file or to top of the "pioneer3dx_urdf.launch".

Lastly, after launching "pioneer3dx.gazebo.launch" file, the links connected to base_swivel_joint and swivel_hubcap_joint cannot be visualized properly in rviz since these joints' states aren't published by gazebo, and robot_state_publisher cannot publish corresponding tf messages. Yet, I'm not sure how and where this can be added for the moment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-04 07:57:45 -0600

Seen: 2,017 times

Last updated: Sep 07 '11