ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

perception_pcl error with flann

asked 2011-03-03 09:41:11 -0500

Eponymous gravatar image

updated 2011-03-03 11:20:22 -0500

Eric Perko gravatar image

Getting an error as if it doesn't know about flann when I

rosmake perception_pcl --rosdep-install

The error is:

~/ros/perception_pcl/pcl/include/pcl/kdtree/kdtree_flann.h:44:27: error: flann/flann.hpp: No such file or directory

It's followed up by a series of similar complaints from other lines in the .h file.

edit retag flag offensive close merge delete


Can you update your post to include how you installed ROS and perception_pcl? Are you trying to use cturtle/diamondback/unstable? What is the output of `rospack find flann`?
Eric Perko gravatar image Eric Perko  ( 2011-03-03 10:43:17 -0500 )edit
Diamondback on Mac OS X 10.6.6. I had previously gotten perception_pcl running and just got this error with the latest upgrade to diamondback which I installed via rosinstall and the url for the full desktop version. flann installs just fine, and rospack find finds it perfectly too.
Eponymous gravatar image Eponymous  ( 2011-03-03 14:19:14 -0500 )edit
More detail:v. 0.10.0 of perception_pcl and perception_pcl_addons/trunk/pcl_visualization at revision 36356.
Eponymous gravatar image Eponymous  ( 2011-03-04 00:03:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2011-03-05 09:36:38 -0500

Eponymous gravatar image

Did another rosinstall and got the latest build of perception_pcl which seems to work. I'm not sure what the problem was though.

flann still has the name_install_tool section commented out; I'm not sure why since it's necessary to have the correct location for libflann_cpp or , so I think you have to do it manually if the Makefile doesn't. So my Makefile has for that:

if [ `uname` = Darwin ]; then \
    install_name_tool -id `rospack find flann`/lib/libflann_cpp.1.6.dylib lib/libflann_cpp.1.6.7.dylib; \

Note that you have to fix the whole path. Can somebody confirm and fix this in svn? I see it's still in flann 1.6.8.

Also I removed all refs to lib64 in the flann manifest.xml. pcl_ros still refers to it and complains in the log file, but it doesn't have any effect that I have so far observed on pcd_viewer. Not sure about other things. Here's what my manifest.xml for flann has in the <export> section (I removed the angle brackets which were affecting display of the code):

cpp cflags="-I${prefix}/include" lflags="-Wl,-rpath,${prefix}/lib -Wl,-rpath,${prefix}/lib -L${prefix}/lib -L${prefix}/lib -lflann_cpp -lhdf5_cpp -lhdf5"

Again if flann isn't actually using a lib64 directory, this should be removed from the manifest.xml in svn.

edit flag offensive delete link more


to get a patch applied to source code please open a ticket.
tfoote gravatar image tfoote  ( 2011-03-08 10:23:53 -0500 )edit

Question Tools


Asked: 2011-03-03 09:41:11 -0500

Seen: 749 times

Last updated: Mar 05 '11