Ask Your Question
0

"Time jumped forward" in gmapping

asked 2013-10-20 00:01:50 -0500

WLemkens gravatar image

I'm using slam_gmapping like in link:this tutorial, but with a live scanner and I'm getting messages like "Time jumped forward by [0.010211] for timer of period [0.010000], resetting timer (...)".

I am running it from a single computer (except rqt_logger_level) so I guess clock synchronisation shouldn't be the cause. But I updated both clocks with ntpdate to be sure (which didn't help).

I noticed that the problem seems to get worse if there is more load on the computer. Could the load be the cause? And in that case is there a way to increase the size of the allowed time jumps? (Or is there an other way to reduce the load for gmapping?)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-11 14:42:49 -0500

cognitiveRobot gravatar image

Hi WLemkens,

you can follow 1 Answer from http://answers.ros.org/question/94671/error-in-creating-2d-global-map-of-the-environment/#99961

let me know if it works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-20 00:01:50 -0500

Seen: 580 times

Last updated: Nov 11 '13