Ask Your Question
0

how to install gscam

asked 2013-10-16 19:20:11 -0600

robotnewbie gravatar image

tried to install gscam in hydro but was unsuccessful following several answers on here for previous distributions of ros.

can anyone help me out with a simple set of terminal instructions for hydro?

Please and thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-10-16 19:58:29 -0600

jbohren gravatar image

After installing ros, all you should have to execute is:

sudo apt-get install ros-hydro-gscam
edit flag offensive delete link more

Comments

thanks but after I do that, i still get these errors when I run rosmake gscam, it gives me an error saying "mkdir: cannot create directory 'build': Permission denied. also if I try to run the tutorial here http://wiki.ros.org/face_recognition (under number 4) I can't roscd to gscam/bin since it doesn't, also running the second command gives me an error

robotnewbie gravatar imagerobotnewbie ( 2013-10-16 20:46:09 -0600 )edit
1

You don't need to build it if you install it via debian package like above.

jbohren gravatar imagejbohren ( 2013-10-16 20:48:17 -0600 )edit

Additionally, that tutorial is out of date and relates to an older version of gscam.

jbohren gravatar imagejbohren ( 2013-10-16 20:52:18 -0600 )edit

thank for your help, appreciate it. Looking at this tutorial http://wiki.ros.org/face_recognition, (scroll down to 4 - Tutorial) it says to do roscd gscam/bin (but I don't have a bin folder!) and if I try to do rosrun gscam gscam /gscam/image_raw:=/camera/image_raw then it gies me an error saying that GSCAM_CONFIG environment variable is not set and 'gscam_config' is not set

robotnewbie gravatar imagerobotnewbie ( 2013-10-16 20:54:58 -0600 )edit

oh was typing up my comment so didnt see your "Additionally" comment til after I posted. should I be worred that I don't have a bin folder though? none of the commands i find to run gscam work for me

robotnewbie gravatar imagerobotnewbie ( 2013-10-16 20:59:45 -0600 )edit

First, the new version of gscam conforms the proper ROS camera API (http://wiki.ros.org/camera_drivers) Second, as the error says, you need to either set the $GSCAM_CONFIG environment variable or the gscam_config ROS parameter to use the program. You can see examples here ( http://github.com/ros-drivers/gscam/tree/master/examples )

jbohren gravatar imagejbohren ( 2013-10-16 21:02:35 -0600 )edit

The executables that would be built into a package's "bin" folder in a rosbuild-based package, when installed, are placed in /opt/ros/$ROS_DISTRO/lib/package-name/. The gscam executable, for example, should be in /opt/ros/hydro/lib/gscam/gscam You can examine the files installed by any package in the synaptic package manager.

jbohren gravatar imagejbohren ( 2013-10-16 21:15:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-16 19:20:11 -0600

Seen: 3,403 times

Last updated: Oct 16 '13