ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Troubles installing ROS C turtle base

asked 2011-02-21 06:35:05 -0500

George gravatar image

updated 2011-03-01 12:02:00 -0500

Hi there,

I am following step by step the directions reported on this web page to install ROS Cturtle on Ubuntu 10.10. However, when I try to install the package (step 1.4), I received a message like:

Reading package lists... Done Building dependency tree
Reading state information... Done E: Unable to locate package ros-cturtle-base

I also tried the other packages (ROS only and PR2), but I got the same message. Same thing if I click on the link suggested on the web page.

What am I doing wrong? I apologize if my question sounds very basic, but I am beginner with Linux and with programming in general.

Thanks in advance for your help!

Cheers, George

Update: Hi guys,

thank you for you reply. I don't know what to say... I tried to re-install everything yesterday (following carefully the directions), and I obtained the same result as before. I tried today, and I got a different error message (see below). I tried multiple times, but I obtained always the same result.

Why this difference? What did I do wrong now? I know that most likely it is my bad, but is it possible that there is some problems in the repository?

Thank you, George

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ros-cturtle-base : Depends: ros-cturtle-ros-tutorials (= 0.2.4-s1297126046~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-geometry-tutorials (= 0.1.3-s1297208879~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-joystick-drivers-tutorials (= 1.4.0-s1297127970~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-slam-gmapping (= 1.2.2-s1295083305~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-joystick-drivers (= 1.2.2-s1295082139~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-ros (= 1.2.4-s1295078370~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-visualization (= 1.2.2-s1295084832~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-camera-drivers (= 1.2.8-s1297313372~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-vision-opencv (= 1.2.5-s1295082686~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-rx (= 0.0.1-s1295080202~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-image-pipeline (= 1.2.2-s1295083182~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-sound-drivers (= 1.2.0-s1295084310~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-simulator-stage (= 1.2.4-s1296091028~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-image-common (= 1.2.0-s1295082600~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-common-tutorials (= 0.1.2-s1297390611~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-imu-drivers (= 1.2.1-s1295085951~jaunty) but it is not going to be installed
                    Depends: ros-cturtle-ros-comm (= 0.0 ...
(more)
edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2011-02-23 06:11:32 -0500

dornhege gravatar image

I think you mangled the package sources.

Jaunty is not 10.10.

Can you check your /etc/apt/sources.list.d/ros-latest.list (or similar)? It should say maverick and not jaunty.

If that is OK, what does apt-cache policy ros-cturtle-base give you?

edit flag offensive delete link more
1

answered 2011-02-21 08:00:42 -0500

John Hoare gravatar image

Are you sure you ran "sudo apt-get update" before you tried to install the package?

edit flag offensive delete link more
0

answered 2011-02-23 06:07:58 -0500

tfoote gravatar image

It appears that you have added the jaunty sources into your apt sources not maverick. You need to audit your apt souces and remove references to jaunty and add them for maverick.

edit flag offensive delete link more
0

answered 2011-02-22 08:27:08 -0500

joq gravatar image

It pretty much has to be either the sudo apt-get update (as John Hoare said), or one of the commands from steps 1.2 and 1.3. There are not many things that can go wrong.

If the update does not work, please retry the installation (carefully) once again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-21 06:35:05 -0500

Seen: 564 times

Last updated: Mar 01 '11