Ask Your Question
1

Setting up OMPL on a non-PR2 robot

asked 2011-02-20 22:13:50 -0500

Hi guys,

I am trying to set up some basic planning with a Schunk arm. I am not concerned with obstacle avoidance at the moment. I tried the interpolated_ik_motion_planner as a simple solution, but very often it complains that there is no IK solution for the problem. So I decided to try OMPL.

The first (of a series of) question is: If I check the topics ompl_planning subscribes to, it lists /joint_states of unkown (!!) type. I provided to feed it with sensor_msgs/JointState messages, but it complains that the message is wrong:

"Planning environment received invalid joint state"

So, what should I give it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-02-21 03:44:27 -0500

Sachin Chitta gravatar image

Hi Lorenzo,

/joint_states is indeed a subscription to a message of type sensor_msgs/JointState. Can you check the following for this message:

(a) make sure joint_state.position.size() == joint_state.name.size() (b) make sure joint_state.velocity.size() == joint_state.name.size()

Planning environment checks the message to make sure that all the fields are filled in and prints that error if it finds that they are not. This probably requires better output. I have opened a ticket to that effect https://code.ros.org/trac/wg-ros-pkg/ticket/5041

edit flag offensive delete link more

Comments

I checked and it is a JointState. The driver for the Schunk arm did not provide a velocity vector. I changed the code and hopefully you will see the changes soon in the repository. And yes, a better output would be useful. Thanks for you help!
Lorenzo Riano gravatar imageLorenzo Riano ( 2011-02-21 19:53:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-20 22:13:50 -0500

Seen: 444 times

Last updated: Feb 21 '11