Ask Your Question
1

Fail to rosmake

asked 2013-10-10 17:00:00 -0500

FuerteNewbie gravatar image

updated 2013-11-18 19:19:51 -0500

tfoote gravatar image
weiyang@ubuntu:~/fuerte_workspace/sandbox/robot_setup_tf$ rosmake
[ rosmake ] rosmake starting...                                                 
[ rosmake ] No package or stack specified.  And current directory 'robot_setup_tf' is not a package name or stack name.
[ rosmake ] Packages requested are: []                                          
[ rosmake ] Logging to directory /home/weiyang/.ros/rosmake/rosmake_output-20131011-105536
[ rosmake ] Expanded args [] to:
[]                                             
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

It was my previously backup package before I reinstall my ubuntu which referring to the tf tutorial. Why am I not able to rosmake it right now? It suppose to be working like other package that I paste into current workspace.

edit retag flag offensive close merge delete

Comments

How is the workspace set up?

dornhege gravatar image dornhege  ( 2013-10-10 23:57:02 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
4

answered 2013-10-10 22:20:04 -0500

davinci gravatar image

The package is not in your package path probably. Try

export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:`pwd`

and rosmake again.

edit flag offensive delete link more

Comments

Hi Davinci, I'm having same problem. above method didn't work. I installed using as http://nootrix.com/2012/05/ros-installation/ then i downloaded sicktoolbox. trying to rosmake without any luck. please help.

cognitiveRobot gravatar image cognitiveRobot  ( 2013-10-14 01:47:15 -0500 )edit

You should execute the command in the package that you are trying to build and then do rosmake after that. Check that the package is indeed in your package path by typing echo $ROS_PACKAGE_PATH

davinci gravatar image davinci  ( 2013-10-14 04:36:47 -0500 )edit

One best way is paste this command into your .bashrc file. It certainly helps.

FuerteNewbie gravatar image FuerteNewbie  ( 2013-10-24 17:51:45 -0500 )edit
1

Hi,I add this line to my ~/.bashrc .It didn't work for me.I try echo $ROS_PACKAGE_PATH.It shows:/path/to/pr2_dashboard:/opt/ros/indigo/share:/opt/ros/indigo/stacks(my command is $ rosmake pr2_dashboard). any ideas?

newer92 gravatar image newer92  ( 2017-03-12 04:10:30 -0500 )edit
0

answered 2015-01-03 13:42:59 -0500

Alexandre.Willame gravatar image

You don't seem to have beginner_tutorials in your ROS_PACKAGE_PATH.

You should probably add this line to your ~/.bashrc (after the line which sources the ROS setup.bash):

export ROS_PACKAGE_PATH=/path/to/beginner_tutorials:${ROS_PACKAGE_PATH}
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-10 17:00:00 -0500

Seen: 8,426 times

Last updated: Jan 03 '15