Ask Your Question
1

Oculus Rift rviz plugin - "No Oculus evice found"

asked 2013-10-10 12:17:11 -0500

Kel gravatar image

updated 2014-01-28 17:18:12 -0500

ngrennan gravatar image

Hello,

I am trying to get the Oculus Rift working with rviz using the oculus_rviz_plugin and the oculus_sdk packages. I have tried a couple of ways and nothing seems to work.

I am running Ubuntu 12.04, ROS Hydro.

I started by grabbing the oculus drivers (0.2.4) from the oculus dev website. With their demo, I see video fine, and the head tracker works fine. (I did this with mirrored screens, one being the oculus and one being my monitor). One thing to note, the device config utility that came with the oculus drivers show "no device found" even though the device was clearly enumerated in the command line output, and the demo worked as expected.

I then installed the debian packages for the rviz plugin and oculus sdk, set the oculus as a separate monitor, and ran rviz. When I loaded in the OculusDisplay plugin, I get the following output:

OVR::DeviceManagerThread - running (ThreadId=0x7fc780051700).
OVR::DeviceManager - initialized.
OVR::DeviceManager - shutting down.
OVR::DeviceManagerThread - exiting (ThreadId=0x7fc780051700).

and the plugin status shows an error with the message "No Oculus device found!".

I have tried both connecting the oculus with DVI and HDMI (via a dvi to hdmi cable, my graphics card doesn't have hdmi natively). I have tried several usb ports (2.0 and 3.0).

I have also tried compiling both rviz and oculus_rviz_plugin from source (both from hydro-devel) with the same behavior.

Could it be that I messed things up by running the configure script that came with the Oculus SDK from their website?

What confounds me is that the oculus example (though the config utility, and rviz, report no device) works fine with video and perfect head tracking.

Has anyone experienced similar? Let me know if you need more information.

Any help would be appreciated.

Cheers!

Kel

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-21 04:46:09 -0500

mmedvede gravatar image

I just had a similar problem while using ros-hydro-oculus-sdk 0.2.3 with oculus-rviz-plugin. The oculus was not detected and failed to work with rviz. The problem was the wrong resolution of the secondary display (OVR) I accidentally set. As soon as I set the resolution back to 1280x800, everything started working. So if you have a similar problem, make sure the resolution is correct. It cost me 3 hours.

I think it should be considered a bug of linux OculusSDK. OculusSDK 0.2.5 still fails to detect the HMD if resolution is not what it expects. I am running Ubuntu 12.04

edit flag offensive delete link more
2

answered 2013-10-11 07:14:45 -0500

dgossow gravatar image

The configure script and the oculus_sdk package both install udev rules. If you've run the install script from a newer sdk version, maybe it has installed an incompatible udev rule. Remove that file from /etc/udev/rules.d so only 90-oculus-hydro.rules is in there.

edit flag offensive delete link more
0

answered 2014-09-19 16:43:24 -0500

Fred Eduardo gravatar image

I am having the same issue here, can you please clarify what you deleted from /lib/udev/rules.d to solve it? and what about /etc/udev/rules.d?

I have the following at /etc/udev/rules.d : 70-persistent-cd.rules 70-persistent-net.rules 90-oculus-groovy.rules READM and at /lib/udev/rules.d I have a bunch of rules, but nothing related to the oculus.

edit flag offensive delete link more
0

answered 2013-10-11 09:05:08 -0500

Kel gravatar image

The Oculus SDK had actually installed the udev rules to /lib/udev/rules.d. Once I removed it, it works perfectly. Thanks so much for the help! I really appreciate it! Cheers, Kel

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2013-10-10 12:17:11 -0500

Seen: 2,127 times

Last updated: Sep 19 '14