Ask Your Question
0

hector package problems

asked 2013-10-09 07:48:52 -0500

End-Effector gravatar image

I have ros hydro full and I installed the hector_slam package with the command

sudo apt-get install ros-hydro-hector-slam

I then tried to follow the tutorial but I had several problems.

when I try the command "rosmake hector_slam" I get multiple errors like this:

"[ rosmake ] WARNING: The stack "hector_geotiff" was not found. We will assume it is using the new buildsystem and try to continue..."

I think it does not work because in the end it says:

"[ rosmake ] Built 0 packages with 0 failures."

I continued the tutorial after this because I have no ideia on what to do, and I did the command

"roslaunch hector_slam_launch tutorial.launch"

It gives me the following error:

"while processing /opt/ros/hydro/share/hector_geotiff/launch/geotiff_mapper.launch: Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/opt/ros/hydro/share/hector_geotiff/launch/geotiff_mapper.launch'"

I really lost now. I can't even start the tutorial.

thx so much for the help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-10-09 11:38:53 -0500

End-Effector gravatar image

I don't know if its against the rules responding to my own question, but I solved the problem.

The sudo apt-get command doesn't update the hector_slam library.

It's not the most recent one. I found that there are missing files in the hector_geotiff paste.

edit flag offensive delete link more

Comments

It's great to answer your own question. This will help anyone who has the same problem, and others won't spend time trying to answer it again.

tfoote gravatar imagetfoote ( 2013-10-09 17:13:45 -0500 )edit

Where did you find the missing files? It sounds like there's a bug in the hector_slam packaging.

tfoote gravatar imagetfoote ( 2013-10-09 17:15:06 -0500 )edit
1

answered 2013-10-10 00:13:00 -0500

The launch files of packages hector_geotiff and hector_imu_attitude_to_tf were missing in version 0.3.0 of hector_slam in ROS hydro. I released version 0.3.1 which fixes the launch files issue and some other minor bugs yesterday. The new version should be available in the public repositories within the next days.

You do not have to invoke rosmake at all if you install the binary packages using sudo apt-get install ros-hydro-hector-slam. If you do, it is normal that no packages will be built as they already are.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-09 07:48:52 -0500

Seen: 823 times

Last updated: Oct 10 '13