Ask Your Question

rosmake tum_ardrone

asked 2013-10-09 07:32:36 -0500

juicedatom gravatar image

updated 2013-10-31 02:08:02 -0500

AHornung gravatar image

Hey All, I am having some trouble compiling the tum_ardrone package. It gets to the last step when I get this error,

  SIMD support:
  mmx mmxext sse sse2 sse3

  Missing SIMD support for x86_64-unknown-linux-gnu:

Does this just mean that I can't compile it on a 64 bit machine? Or do I need a different type of linux? I am currently running Ubuntu 13.02.

Thank You!

edit retag flag offensive close merge delete


Is that really 13.02? please give the full context of the error. What SIMD instruction sets do you think are available on your machine?

tfoote gravatar image tfoote  ( 2013-10-09 17:23:52 -0500 )edit

I am getting the same error

Artem gravatar image Artem  ( 2013-10-31 00:50:58 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2013-10-31 01:00:36 -0500

Artem gravatar image

updated 2013-10-31 03:01:04 -0500

The error log is this

SIMD support: mmx mmxext sse sse2 sse3

Missing SIMD support for x86_64-unknown-linux-gnu:

-g -Wall -Wextra -pipe -ggdb -fPIC -mmmx -msse -msse -msse2 -msse3 -pthread -ltiff -ljpeg -lpng -lpng -lGLU -lGL -lrt -L -lX11 -lXext -pthread Generating config... configuration unchanged configure: creating ./config.status config.status: creating Makefile cd build && export CPATH=../../TooN/include && make make[3]: Entering directory /home/rpserver/ros/rosbuild/stacks/tum_ardrone/thirdparty/libcvd/build' g++ -O3 -I. -I. -INONE/include -g -Wall -Wextra -pipe -ggdb -fPIC -mmmx -msse -msse -msse2 -msse3 -pthread -c progs/ -o progs/video_play_source.o progs/ In function ‘void play(std::string)’: progs/ error: there are no arguments to ‘usleep’ that depend on a template parameter, so a declaration of ‘usleep’ must be available [-fpermissive] progs/ note: (if you use ‘-fpermissive’, G++ will accept your code, but allowing the use of an undeclared name is deprecated) progs/ In instantiation of ‘void play(std::string) [with C = CVD::Rgb<unsigned char>; std::string = std::basic_string<char>]’: progs/ required from here progs/ error: ‘usleep’ was not declared in this scope In file included from ./cvd/internal/convert_pixel_types.h:27:0, from ./cvd/image_convert.h:25, from ./cvd/colourspacebuffer.h:27, from ./cvd/videosource.h:13, from progs/ ./cvd/internal/scalar_convert.h: At global scope: ./cvd/internal/scalar_convert.h:112:21: warning: ‘CVD::Pixel::Internal::init_float_for_byte’ defined but not used [-Wunused-variable] ./cvd/internal/scalar_convert.h:113:21: warning: ‘CVD::Pixel::Internal::init_double_for_byte’ defined but not used [-Wunused-variable] make[3]: *** [progs/video_play_source.o] Error 1 make[3]: Leaving directory/home/rpserver/ros/rosbuild/stacks/tum_ardrone/thirdparty/libcvd/build' make[2]: * [libcvd_built] Error 2 make[2]: Leaving directory /home/rpserver/ros/rosbuild/stacks/tum_ardrone/thirdparty/libcvd' make[1]: *** [all] Error 2 make[1]: Leaving directory/home/rpserver/ros/rosbuild/stacks/tum_ardrone/thirdparty' make: * [all] Error 2

The solution is to add

#include <unistd.h> // it defines usleep()



This compilation issue is used to be a warning, nowadays compilers become more strict, so it is an error now.

*EDIT Not really a general solution, there are many other errors occurred after.

                   from /home/rpserver/ros/rosbuild/stacks/tum_ardrone/src/autopilot/KI/../DroneController.h:27,
                   from /home/rpserver/ros/rosbuild/stacks/tum_ardrone/src/autopilot/KI/KIProcedure.h:26,
                   from /home/rpserver/ros/rosbuild/stacks/tum_ardrone/src/autopilot/KI/KIFlyTo.h:25,
                   from /home/rpserver/ros/rosbuild/stacks/tum_ardrone/src/autopilot/KI/KIFlyTo.cpp:21:
  /home/rpserver/ros/rosbuild/stacks/tum_ardrone/thirdparty/TooN/include/TooN/internal/debug.hh:100:33: note: ‘template<class P> void TooN::Internal::debug_initialize(P*, int)’ declared here, later in the translation unit
  Linking CXX executable ../bin/drone_gui
  In file included from /home/rpserver/ros/rosbuild/stacks/tum_ardrone/thirdparty/TooN/include/TooN/TooN.h:250:0,
                   from /home/rpserver/ros/rosbuild/stacks/tum_ardrone ...
edit flag offensive delete link more

answered 2014-03-27 01:23:51 -0500

devesh gravatar image

The above link helped me solve it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-10-09 07:32:36 -0500

Seen: 1,416 times

Last updated: Mar 27 '14