Ask Your Question
1

Issues installing stage/stage_ros from source on hydro

asked 2013-10-06 16:02:13 -0600

jgilsenan gravatar image

Hello All,

So I recently upgraded to Ubuntu 13.04 at which time I was forced to switch from ROS fuerte to one of the newer distros, in this case Hydro.

I have been working on developing my own "navigation stack" for fuerte for several months now and have been doing all of my simulations in stage. After installing Hydro and catkinizing all of my fuerte packages the last thing I need to do is install stage and I am having some issues doing so.

I understand that stage for ros has now been changed to a two-part setup with a 'stage' and 'stage_ros' package, both of which are automatically installed with hydro-desktop-full, however I want to install them from source in my catkin workspace so that I can more easily edit the wrapper.

On the ROS wiki there are listed git's for each at: https://github.com/rtv/Stage and https://github.com/ros-simulation/stage_ros however that is where the description of the new setup ends.

I have tried downloading the two git's but when I try and build my catkin workspace I receive the following errors:

-- checking for module 'stage' -- package 'stage' not found CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (message): Could NOT find Stage (missing: Stage_LIBRARIES Stage_INCLUDE_DIRS) Call Stack (most recent call first): /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE) stage_ros/cmake/StageConfig.cmake:23 (find_package_handle_standard_args) stage_ros/CMakeLists.txt:11 (find_package)

-- Configuring incomplete, errors occurred! Invoking "cmake" failed

Has anyone tried installing stage manually for ROS Hydro and could help me?

edit retag flag offensive close merge delete

Comments

1

Did you ever find a solution? i'm having this same issue.

Woodrow Douglass gravatar imageWoodrow Douglass ( 2013-11-15 02:28:15 -0600 )edit

I Installed it successfully in Ubuntu 12.04 and Hydro, but now I'm trying to install it in 14.04 and Indigo, but doesn't work.

gustavo.velascoh gravatar imagegustavo.velascoh ( 2014-05-09 09:27:28 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-09 10:17:29 -0600

updated 2014-05-11 16:11:22 -0600

First, I copied stage.pc to /opt/ros/<distro>/lib/pkgconfig/ and when I catkin_make, cmake runs fine, but make throws an error. So I uninstall libfltk-1.3 and install libfltk-1.1. After this make finish well and create stageros executable, but doesn't run; Segmentation fault (core dumped) message appears.

EDIT:

FInally worked. I re-install stage with libfltk1.1, and then catkin_make runs fine. After this stageros works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-10-06 16:02:13 -0600

Seen: 533 times

Last updated: May 11 '14