/lib/modules/3.0.0-32-generic-pae/build not found

asked 2013-09-30 01:09:37 -0500

hvn gravatar image


Using "rosmake" I found that /lib/modules/3.0.0-32-generic-pae/build directory is missing during compilation. Using "make" I get no error. Following thread http://ubuntuforums.org/showthread.php?t=1745310 I installed linux-libs-dev package, but I still get the same error. Can anyone tell me what I may be doing wrong ?


edit retag flag offensive close merge delete


That's a very unusual directory. Please provide more information about how to reproduce the problem. http://wiki.ros.org/Support

tfoote gravatar image tfoote  ( 2013-10-06 21:42:11 -0500 )edit

The node (I didnt write it) is a hardware driver. During rosmake the last output before the error is make -C /lib/modules/3.0.0-32-generic-pae/build M=/home/<user>/<path>/driver modules make: Entering an unknown directory make: *** /lib/modules/3.0.0-32-generic-pae/build: No such file or directory

hvn gravatar image hvn  ( 2013-10-06 22:08:46 -0500 )edit

What driver are you trying to compile? How can your problem be reproduced?

tfoote gravatar image tfoote  ( 2013-10-06 22:10:02 -0500 )edit

I'm trying to compile a driver (orocos wrapper) for an arm. I asked the original writer and he can compile it, though he uses newer ROS and Ubuntu versions by now. The problem can be reproduced by just going to the node by "roscd <node>" and running rosmake.

hvn gravatar image hvn  ( 2013-10-06 22:27:18 -0500 )edit

OK, found this problem. I was convinced I had the kernel headers installed...but didn't for this specific kernel. The problem I'm facing now is that the driver was written for a pre-2.6.36 kernel. So need to change source files.

hvn gravatar image hvn  ( 2013-10-07 04:28:55 -0500 )edit