Ask Your Question
1

synchronized problem related to calibration

asked 2013-09-28 13:48:07 -0600

Dava2788 gravatar image

updated 2013-10-06 16:41:24 -0600

Hello All.

I Am a rookie in Ros, I am using ros fuerte and a monocular camera. My lapto's camera.

I want to know how many things I need to setup to make a retification image with image_proc package.

I already setup a launch file, I attached

But when I ran the image_view to display the image rectify, I got nothing. And when I ran the image_view to display the image mono, it works.

So I want to know what things I have to setup to do a rectification image. And what thing I did wrong.

I attached the rxgraph output, my launch file and my camera parameters

Besides I have a warning:

[image_transport] Topics '/Dava/image_mono' and '/Dava/gscam/camera_info' do not appear to be synchronized. In the last 10s: Image messages received: 80 CameraInfo messages received: 80 Synchronized pairs: 0

I will appreciate any respond . Thank you

image description

image description

Output.png

Test_Launch.png

you can download the launch file to this link: https://mega.co.nz/#!fohxhQYY!RIuUOVuf1mL8Nn_erxkrujVt8zUmsLn-4_kP2YokMxc

edit retag flag offensive close merge delete

Comments

What is the output of `rosconsole` when you start your launch file?

Thomas gravatar imageThomas ( 2013-09-30 15:29:07 -0600 )edit

I just uploaded

Dava2788 gravatar imageDava2788 ( 2013-10-01 08:35:54 -0600 )edit

Apparently the camera information is not correctly synchronized, this may be a bug of gscam. Also, camera information may be incorrect and rejected, hence the lack of data. Can you copy and paste in your original question two or three outputs of this topic?

Thomas gravatar imageThomas ( 2013-10-06 19:22:33 -0600 )edit

@Thomas this is a bug from the old (svn) version of gscam, and has been fixed for months in the released version.

jbohren gravatar imagejbohren ( 2013-10-07 01:38:04 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-10-07 01:38:53 -0600

jbohren gravatar image

The code you are using is out of date. The sync bug has been fixed in the current released versions of gscam (0.1.1), the source versions of which can be found here: https://github.com/ros-drivers/gscam

edit flag offensive delete link more

Comments

Thank you. I will download it. Final question, one of these version works in ROS FUERTE, right?

Dava2788 gravatar imageDava2788 ( 2013-10-07 06:54:54 -0600 )edit

Yes, gscam 0.1.1 can be built in a rosbuild-based workspace.

jbohren gravatar imagejbohren ( 2013-10-07 06:56:27 -0600 )edit

Thank you, jbohren.

Dava2788 gravatar imageDava2788 ( 2013-10-07 06:58:57 -0600 )edit

@Dava2788 so did it work?

jbohren gravatar imagejbohren ( 2013-10-08 07:47:02 -0600 )edit

I'm going to test it this afternoon. I will let you know.

Dava2788 gravatar imageDava2788 ( 2013-10-08 08:15:42 -0600 )edit

@jbohren, thanks it work, I could see the rectify image. But I just have another problem, when I tried to Subscribed that topic (Image_rect) to another node (Viso2). It show again the sync msg (warning message). I don't know if I'm doing something wrong with the configuration with viso2 or is gscam

Dava2788 gravatar imageDava2788 ( 2013-10-08 14:38:37 -0600 )edit

I going to close this question and open a new one if I stil have this issue. Thanks @jbohren.

Dava2788 gravatar imageDava2788 ( 2013-10-08 15:14:42 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-28 13:48:07 -0600

Seen: 779 times

Last updated: Oct 07 '13