/robot_pose_ekf debug messages [closed]

asked 2013-09-23 22:46:16 -0500

redheli gravatar image

Hi,

I have a kobuki mobile base and installed kinect as sensor to localization. The big problem is both gmapping and amcl are bad. the laser scan can not match the map. and first step of troubleshoot, I find /robot_pose_ekf output a lot of repeated debug message, as below:

my question is : are these msgs related to the localization issue? Thanks.

TF operating on not fully resolved frame id imu, resolving using local prefix 
TF operating on not fully resolved frame id base_footprint, resolving using local prefix 
    AddMeasurement from odom_combined to base_footprint:  (0.000000, 0.000000, 0.000000)  (0.000000, 0.000000, 0.000000, 1.000000)
        TF operating on not fully resolved frame id base_footprint, resolving using local prefix 
        TF operating on not fully resolved frame id odom_combined, resolving using local prefix 
        TF operating on not fully resolved frame id odom_combined, resolving using local prefix 
        TF operating on not fully resolved frame id base_footprint, resolving using local prefix 
        TF operating on not fully resolved frame id odom_combined, resolving using local prefix

lauch file:

<launch>


    <node pkg="robot_pose_ekf" type="robot_pose_ekf" name="robot_pose_ekf">
                <!--remap from="odom" to="/mobile_base/odom" /-->
        <remap from="imu_data" to="/mobile_base/sensors/imu_data" />
        <remap from="robot_pose_ekf/odom" to="/odom_combined"/>
        <param name="freq" value="50.0"/>
        <param name="sensor_timeout" value="0.5"/>
        <param name="odom_used" value="true"/>
        <param name="imu_used" value="true"/>
        <param name="vo_used" value="false"/>
        <param name="self_diagnose" value="false"/>
        <param name="output_frame" value="odom_combined"/>
    </node>
</launch>
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-08 00:26:11.836172

Comments

Which ROS version are you using? On hydro, robot_pose_ekf is not used for kobuki/TB2 anymore

jorge gravatar image jorge  ( 2013-09-23 23:15:50 -0500 )edit

Hi Jorge, I am using groovy. can tell the reason why not use robot_pose_ekf? actually the data of /odom_combined (publish by robot_pose_ekf) is ok. I drive the TB2 around and monitor the data.

redheli gravatar image redheli  ( 2013-09-24 00:13:53 -0500 )edit
1

Kobuki comes with a factory calibrated imu that provides more precise heading than the encoders, so we just rely on it for heading, and on encoders for position. Like this, we avoid the extra computing and latency of using robot_pose_ekf.

jorge gravatar image jorge  ( 2013-09-24 13:51:27 -0500 )edit

In groovy, as imu heading had much lower covariance than odom, it overshadowed encoders, so if you move to hydro you will appreciate almost no difference.

jorge gravatar image jorge  ( 2013-09-24 13:52:55 -0500 )edit

That said, I think these msgs are not related to the localization issue. So can you provide more details on the problem? what you launch, etc.

jorge gravatar image jorge  ( 2013-09-24 13:57:59 -0500 )edit

Thank you Jorge. use encoder for position and imu for heading is good idea. and I also notice parameter "use_imu_heading" in kobuki_node. I tested with set it ture/false, both not improve the localization. I will test without robot_pose_ekf. and open another post about my TB2 localization issue. Thank you again.

redheli gravatar image redheli  ( 2013-09-24 15:30:48 -0500 )edit

Welcome. use_imu_heading appears on hydro; set as false allows you to re-introduce the discarded robot_pose_ekf.

jorge gravatar image jorge  ( 2013-09-24 15:55:45 -0500 )edit

Hi, I have the same problem of mismatching between the map and the laser scanning. The position given from the encoder is false. Did you resolve the problem? Is it only due to bad sensors? I have the problem in simulation. I use a husky robot. Thank you

est_CEAR gravatar image est_CEAR  ( 2014-10-23 04:50:46 -0500 )edit