Ask Your Question
0

RQT_RVIZ RVIZ Remote ROS_IP

asked 2013-09-17 08:09:29 -0500

Chrimo gravatar image

updated 2014-01-28 17:17:58 -0500

ngrennan gravatar image

Hi community,

Hydro-RQT/RViz did not use ROS_IP, ROS_MASTER_URI or ROS_HOSTNAME... "rostopic list" works fine.

Bug or feature ?

Thanks in advance for any suggestion

Cheers Christian

edit retag flag offensive close merge delete

Comments

Please clarify what your problem is in a way that it can be reproduced.

tfoote gravatar image tfoote  ( 2013-09-17 08:15:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-17 10:31:19 -0500

Chrimo gravatar image

Problem solved

Workaround script:

my own ip address from RVIZ Workstation

export ROS_HOSTNAME=/bin/hostname -I

remote headless system MockBot

export ROS_MASTER_URI="http://$1:11311"

echo Using ROS MASTER at $ROS_MASTER_URI from $ROS_HOSTNAME

ping -c 1 $1 rostopic list rosrun rqt_rviz rqt_rviz

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-17 08:09:29 -0500

Seen: 256 times

Last updated: Sep 17 '13