Ask Your Question
0

Unable to subscribe ros topic generated on different architecture machine

asked 2013-09-15 05:52:41 -0500

rock-ass gravatar image

updated 2014-01-28 17:17:58 -0500

ngrennan gravatar image

Hello, I'm working on a project in which I am trying to use my laptop as roscore and using beaglebone black as ros client. I have run into some issue, I cannot make a ros topic which would be readable on both sides (beaglebone and laptop). I tried running the most simple beginner_tutorial talker.py:

  1. I set ROS_MASTER_URI on both machines to my laptops ip address and start roscore.

  2. On beaglebone i run rosrun beginner_tutorials talker.py and everything starts without any errors. I find new topic listed under rostopic list and everything looks fine.

  3. I try to subscribe to messages using rostopic echo /chatter on laptop and nothing appears.
  4. Running rostopic echo /chatter on beaglebone I can see "Hello world" messages.

Both machines are running Ubuntu 12.04 with ROS Groovy installations. Beaglebone has ros-groovy-ros-bare-bones package and laptop has ros-groovy-ros-desktop-full package. It seems communication is fine, but messages is not interpreted on my laptop, maybe someone have some information why can`t I receive messages?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-15 10:12:16 -0500

This is likely a ROS environment configuration issue and not related to the machine architecture. Take a look at the network configuration troubleshooting wiki page.

edit flag offensive delete link more

Comments

Thank you a lot, that helped me, setting ROS_IP enviromental variable on both machines solved the problem, thanks again !

rock-ass gravatar image rock-ass  ( 2013-09-16 11:47:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-15 05:52:41 -0500

Seen: 238 times

Last updated: Sep 15 '13