Problem running PCL Tutorial? [closed]

asked 2013-09-13 09:15:58 -0600

Britsk gravatar image

updated 2013-09-13 09:16:47 -0600

Hi all! I'm using Ubuntu 12.04 I was trying to follow the tutorial here wiki.ros.org/pcl/Tutorials.

At step 4.1 I don't understand what TOP_DIR_YOUR_CATKIN_HOME is... Intuitively, I believed it was the directory ~/my_pcl_tutorial so I made a try.

After doing that the command catkin_make reported error: The specified base path "/home/britsk/my_pcl_tutorial" contains a CMakeLists.txt but "catkin_make" must be invoked in the root of workspace.

I copied the CMakeLists.txt and package.xml files to another place and ran the catkin_make command. It worked and then I restored the files. I'm not sure if this is necessary.

Then I ran: rosrun my_pcl_tutorial example input:=/narrow_stereo_textured/points2. I received another error: rosrun my_pcl_tutorial example input:=/narrow_stereo_textured/points2

I looked around and found sth relating to rosws, so I tried rosws set ~/my_pcl_tutorial and got the error ERROR in config: Command requires a target workspace

Please tell me how to make this tutorial work.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-08 00:36:56.596507