Ask Your Question
4

Asus Xtion on USB 3.0 - ROS-hydro - Ubuntu 12.10

asked 2013-09-09 07:48:40 -0500

Dyna gravatar image

updated 2014-01-28 17:17:53 -0500

ngrennan gravatar image

For a few weeks I want to use pro Xtion, the USB 3.0 ports. I tried in different version of Ubuntu and ROS, but it still does not work. Currently, I'm running Ubuntu 12.10 (64 bits), and hydro ROS. The Xtion USB 2 works well, but when I go to the USB 3.0, I have the following message:

Image: PrimeSense/SensorV2/5.1.0.41: Failed to open the USB device!

Update :

As mentioned in this thread I updated the driver used. But now, even in USB 2.0, I have this message :

Image: PrimeSense/SensorV2/5.1.2.1: Failed to set USB interface!

As mentioned here I update the firmware of my camera, and it works on Windows on USB 3.0.

But unfortunately not with ROS ....

Update 2 :

I try to test OpenNi2 through the package in ros-hydro, when I run rosrun openni2_camera openni2_camera_node, I get the following message:

[INFO] [1378807167.725457003]: Device "1d27/0601 @ 3/3" connected

[WARN] [1378807167.728880859]: ~ device_id is not set! Using first device.
Warning: USB events thread - failed to set priority. This might causes loss of data ...

A little help would be appreciated....

edit retag flag offensive close merge delete

Comments

I know it's not much help but at some point I found an article that stated the firmware on the Xtion has a bug that makes it incompatible with the standards compliant implementation of USB3.0 in the linux kernel. I really hoped that somehow this would be fixed, but I am not optimistic about it.

Dereck gravatar image Dereck  ( 2013-09-10 03:08:13 -0500 )edit

Hello, Thank you for your answer, is it possible to get the link to the article?

Dyna gravatar image Dyna  ( 2013-09-10 04:02:09 -0500 )edit

it was a year ago that I played with it last, so I'm afraid I don't recall the URL. :( If you do get it working on USB 3 please update the ROS wiki and this question though :D

Dereck gravatar image Dereck  ( 2013-09-10 04:17:15 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-09-10 04:33:31 -0500

timm gravatar image

After installing ASUS' USB 3.0 hotfix, have you tried changing the USB interface to bulk endpoints as specified here or here? Quote from the first link:

"To get the device working I used OpenNI Unstable 1.5.4.0 (https://github.com/OpenNI/OpenNI.git) and PrimeSense Sensor Unstable 5.1.2.1 (https://github.com/PrimeSense/Sensor.git)"

"After installing the driver it is necessary to change the "USB interface" that is used to BULK endpoints by uncommenting UsbInterface=2 in GlobalDefaults.ini (/usr/etc/primesense/GlobalDefaults.ini). I've also found it works when the interface is set to 0. The following comment from the file explains the meaning of the parameters: ; USB interface to be used. 0 - FW Default, 1 - ISO endpoints, 2 - BULK endpoints. Default: Arm - 2, other platforms - 1"

edit flag offensive delete link more

Comments

Yeap, I did this....

Dyna gravatar image Dyna  ( 2013-09-10 04:39:26 -0500 )edit

Does this workaround works for Primesense Carmine 1.09?

Keerthi Raj gravatar image Keerthi Raj  ( 2013-12-01 12:41:45 -0500 )edit

@timm: Thank you a lot, I resolved it

domikilo gravatar image domikilo  ( 2014-02-18 17:29:44 -0500 )edit

helped - thx!

RodBelaFarin gravatar image RodBelaFarin  ( 2015-02-20 04:48:14 -0500 )edit
3

answered 2014-03-22 03:15:14 -0500

blizzardroi gravatar image

I had the same problem for OpenNi2

I had to change /etc/openni2/PS1080.ini and set USBInterface = 0

edit flag offensive delete link more
-1

answered 2013-09-10 01:04:03 -0500

Jbot gravatar image

Maybe your issue does not come from ROS or the OpenNi driver but from your kernel version. "Old" kernels don't have a good support of USB3.0 and you need to have at least kernel 3.4.2 to have a correct behavior (to use a kinect with USB3.0, it is needed, I don't know if it's the same with Xtion).

If you have a recent kernel, it may not be the cause of your issues.

edit flag offensive delete link more

Comments

My kernel version is : 3.8.0-30.....

Dyna gravatar image Dyna  ( 2013-09-10 01:37:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-09 07:48:40 -0500

Seen: 12,554 times

Last updated: Mar 22 '14