Ask Your Question
0

When I run roswtf I get several errors now after upgrade in hydro [closed]

asked 2013-09-08 07:35:05 -0500

rnunziata gravatar image

When I run roswtf I get several errors now after upgrade in hydro that I did not get prior.

Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

Found 2 error(s).

ERROR Not all paths in ROS_PACKAGE_PATH [/home/rnunziata/catkin_ws/src:/opt/ros/hydro/share:/opt/ros/hydro/stacks] point to an existing directory: 
 * /opt/ros/hydro/stacks

ERROR Not all paths in PYTHONPATH [/home/rnunziata/catkin_ws/devel/lib/python2.7/dist-packages:/opt/ros/hydro/lib/python2.7/dist-packages] point to a directory: 
 * /home/rnunziata/catkin_ws/devel/lib/python2.7/dist-packages

================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules

Online checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /rosout:
   * /rosout


Unhandled exception in thread started by <bound method TCPServer.run of <rospy.impl.tcpros_base.TCPServer object at 0xa9f1cec>>
Traceback (most recent call last):
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/impl/tcpros_base.py", line 156, in run
    (client_sock, client_addr) = self.server_sock.accept()
  File "/usr/lib/python2.7/socket.py", line 202, in accept
    sock, addr = self._sock.accept()
  File "/usr/lib/python2.7/socket.py", line 170, in _dummy
    raise error(EBADF, 'Bad file descriptor')
socket.error: [Errno 9] Bad file descriptor
edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by rnunziata
close date 2013-09-16 02:51:08

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-11 02:02:57 -0500

rnunziata gravatar image

updated 2013-09-12 07:44:31 -0500

I install ubuntu 13 in dual boot and no longer get this error

edit flag offensive delete link more

Comments

sorry I have Ubuntu 13 and I still have this problem... How did you install ros? From source maybe?

Wojciech gravatar image Wojciech  ( 2013-09-26 03:50:55 -0500 )edit

If by problem you mean Unhandled exception. I installed hydro on Ubuntu 13 in dual boot. NOT VM.

rnunziata gravatar image rnunziata  ( 2013-09-26 04:28:09 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-09-08 07:35:05 -0500

Seen: 310 times

Last updated: Sep 12 '13