Ask Your Question
1

hydro openni apt-get problem

asked 2013-09-04 18:18:59 -0500

mallanmba gravatar image

updated 2013-09-05 08:37:35 -0500

I'm trying to install the hydro turtlebot simulator on Ubuntu 12.04 (32 bit) but the dependencies for openni seem a bit wacky. I've installed and uninstalled a few times now and nothing seems to work. It seems to boil down to ros-hydro-openni-launch refuses to install because it doesn't want to install ros-hydro-openni-camera even if ros-hydro-openni-camera is already installed.

...
The following packages have unmet dependencies:
 ros-hydro-turtlebot-bringup : Depends: ros-hydro-openni-launch but it is not going to be installed
...
 ros-hydro-openni-launch : Depends: ros-hydro-openni-camera but it is not going to be installed
...
ros-hydro-openni-camera is already the newest version.

If I have ros-hydro-openni-camera installed, and then do an "apt-get install ros-hydro-desktop-full", it removes ros-hydro-openni-camera, e.g.

Removing ros-hydro-openni-camera ...
Removing libopenni-dev ...
Removing libopenni-sensor-primesense-dev ...
Removing libopenni-sensor-primesense0 ...
Removing openni-utils ...
Removing libopenni0 ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for man-db ...
Selecting previously unselected package openni-dev.

...and I'm back at square one.

I'm guessing there's a conflict between openni-dev and libopenni-dev Any suggestions as to how to get things installed properly?

Thanks, -Mark

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-09-05 12:09:42 -0500

mallanmba gravatar image

Thanks, all looks good now. For those who were experiencing this problem, do the following:

sudo apt-get update
sudo apt-get dist-upgrade

...then install your ros debs

edit flag offensive delete link more

Comments

Please accept the answer so people know your problem is solved.

tfoote gravatar image tfoote  ( 2013-09-05 12:38:31 -0500 )edit

this did not really worked for me. Please check my problem http://answers.ros.org/question/115546/cannot-install-ros-hydro-on-ubuntu-1204/

pmolina gravatar image pmolina  ( 2014-01-29 23:23:52 -0500 )edit
0

answered 2013-09-05 11:38:30 -0500

tfoote gravatar image

There were out of date pcl debian packages in the repository briefly. They have been fixed. See discussion here: http://lists.ros.org/pipermail/ros-release/2013-September/004204.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-04 18:18:59 -0500

Seen: 1,774 times

Last updated: Sep 05 '13