Ask Your Question
0

Turtlebot Simulator Package and Rviz Crashing.

asked 2013-09-03 17:46:39 -0600

Alkaros gravatar image

updated 2013-09-04 13:03:30 -0600

bit-pirate gravatar image

Currently Running Hydro and the newest version of the turtlebot_simulator Package. Previously teleop commands were not sending but that has been fixed in a newer version I think.

Currently having issues with RViz. It worked prior to the update, now it crashes when point cloud or any sensor is activated. Also, it has never worked with "image"

This was the crash in terminal:

Registered event listener change listener:  true 
[rviz-1] process has died [pid 3635, exit code -11, cmd /opt/ros/hydro/lib/rviz/rviz -d /opt/ros/hydro/share/turtlebot_rviz_launchers/rviz/robot.rviz __name:=rviz __log:=/home/thesis/.ros/log/c61c9da8-1447-11e3-90c8-0026b97f1590/rviz-1.log].
log file: /home/thesis/.ros/log/c61c9da8-1447-11e3-90c8-0026b97f1590/rviz-1*.log

Any ideas?

edit retag flag offensive close merge delete

Comments

Hard to tell what's going wrong with that minimal error log. Does the mentioned log file contain any valuable information? Please also state, which launchers and RViz config files you are using.

bit-pirate gravatar imagebit-pirate ( 2013-09-04 13:02:43 -0600 )edit

Might be https://github.com/ros-visualization/rviz/issues/676. What version of RViz are you using? Please post the contents of the log file.

dgossow gravatar imagedgossow ( 2013-09-04 13:08:41 -0600 )edit

My Rviz Version is 1.10.3. the print out in the logfile rviz-1-stdout.log was not so exciting: http://pastebin.com/UdZyQ8pb. Also I'm using the the turtlebot_rviz_launchers v2.1.1

Alkaros gravatar imageAlkaros ( 2013-09-04 18:03:35 -0600 )edit

Version 2.2.0 is already there. Can you give a try? Also, do you use 32 or 64 bits OS?

jorge gravatar imagejorge ( 2013-09-04 18:50:38 -0600 )edit

32 bit OS. Excuse my ignorance but how do I go about updating. My repositories were up to date before I downloaded it, I believe.

Alkaros gravatar imageAlkaros ( 2013-09-04 20:02:09 -0600 )edit

RViz 1.10.3 had this bug, it's fixed in the most recent release.

dgossow gravatar imagedgossow ( 2013-09-04 21:35:11 -0600 )edit

@Alkaros, if the new RViz version fixes this issue for you, please add a small answer saying so and accept it to close this question. Thx.

bit-pirate gravatar imagebit-pirate ( 2013-09-09 19:46:13 -0600 )edit

Updated my Rviz to 1.10.6. Problem is solved. Didn't get a chance to try it till today. Thanks Guys :)

Alkaros gravatar imageAlkaros ( 2013-09-10 19:10:49 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-10 19:12:26 -0600

Alkaros gravatar image

Error using Rviz 1.10.3. Updating to the newer version 1.10.6 solved this issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-03 17:46:39 -0600

Seen: 588 times

Last updated: Sep 10 '13