Ask Your Question
1

catkin_package INCLUDE_DIR set CFlags to <package>.pc under devel/ but not set CFlags to installspace

asked 2013-08-16 01:47:38 -0500

Kei Okada gravatar image

updated 2014-01-28 17:17:41 -0500

ngrennan gravatar image

Hi,

I have a package with

catkin_project( INCLUDE_DIRS include1 include2 )

and this generate <package>.pc under devel (./devel/lib/pkgconfig/<package>.pc) that contians

Cflags: -I.../include1 -I../include2

but <packge>.pc under build/..../catkin_generated/installspace/<package>.pc becomes

Cflags: -I/tmp/catkin_ws/install/include

It this expected behavior? Why it is not

Cflags -I/tmp/catkin_ws/install/include/<package>/include1 -I/tmp/catkin_ws/install/include/<package>/include2

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-16 06:04:02 -0500

Dirk Thomas gravatar image

This is expected behavior. In install space you should have installed all header (from potentially various locations in source) into a single include folder (following FHS).

edit flag offensive delete link more

Comments

1

With catkin, you need to explicitly install any headers you export. See: http://ros.org/doc/groovy/api/catkin/html/howto/building_libraries.html#installing

joq gravatar image joq  ( 2013-08-16 08:34:49 -0500 )edit

Thanks for the answer! I'm trying to release 3rd-parity library that does not follows FHS standard, using catkin/bloom. Is there any good examples for this?

Kei Okada gravatar image Kei Okada  ( 2013-08-16 16:25:42 -0500 )edit

The link above is the recommended solution.

joq gravatar image joq  ( 2013-08-16 16:33:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-16 01:47:38 -0500

Seen: 518 times

Last updated: Aug 16 '13