Ask Your Question
0

gscam can no longer be run

asked 2013-08-08 00:05:04 -0600

updated 2013-08-08 01:40:05 -0600

I have used gscam for a while and I'm quite happy with it. However, since a week it will no longer start. I get the known 'PAUSED' error, but I don't think any settings have changed. This is the output of running it:

$ rosrun gscam gscam
[ INFO] [1375955831.001182268]: Using gstreamer config from env: "v4l2src 
device=/dev/video0 ! video/x-raw-rgb,framerate=25/1, width=640,height=360 ! ffmpegcolorspace"
[ INFO] [1375955831.004123416]: using default calibration URL
[ INFO] [1375955831.004218662]: camera calibration URL: file:///home/raf/.ros/camera_info/camera.yaml
[ERROR] [1375955831.004328229]: Unable to open camera calibration file [/home/raf/.ros/camera_info/camera.yaml]
[ WARN] [1375955831.004371869]: Camera calibration file /home/raf/.ros/camera_info/camera.yaml not found.
[ INFO] [1375955831.004409639]: Loaded camera calibration from 
[FATAL] [1375955831.121288814]: Failed to PAUSE stream, check your gstreamer configuration.
[FATAL] [1375955831.121384226]: Failed to initialize gscam stream!

The settings of the webcam at dev/video0 are:

$ ls -l /dev/video0
crw-rw-rw-+ 1 raf video 81, 0 aug  7 08:24 /dev/video0

Note that I have read and write permissions set for every user and am myself owner of the device.

I also tried to remove and reinstall gscam, to no avail. Does anyone know what else I can try?

edit retag flag offensive close merge delete

Comments

1

Maybe try with gst-launch to see that you get an image (end with e.g. ximagesink).

TommyP gravatar imageTommyP ( 2013-08-08 04:08:53 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-18 21:21:53 -0600

updated 2013-08-18 21:22:30 -0600

Thanks to the comment of @TommyP, I did:

$ gst-launch v4l2src device=/dev/video0 ! video/x-raw-rgb,framerate=25/1, width=640,height=360 ! ffmpegcolorspace ! ximagesink

Which is what gscam also tries more or less to do. This gave following output:

Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Could not negotiate format
Additional debug info:
gstbasesrc.c(2830): gst_base_src_start (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
Check your filtered caps, if any
Setting pipeline to NULL ...
Freeing pipeline ...

The part where it says "could not negotiate format' indicated that my parameters were faulty, e.i. my camera does not support them.

Using GTK UVC video viewer, I found that the only framerates supported by my webcam are 30/1 and 15/1. gscam works using either one of these.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-08 00:05:04 -0600

Seen: 1,557 times

Last updated: Aug 18 '13