Ask Your Question
0

ROS beginner_tutorials (17th tutorial) Error

asked 2013-08-02 01:45:34 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello, I am trying to learn ROS. So far I had many errors. Thanks to ROS Answers, I found solutions to them so far.

I could not solve this one, so here is my question.

I get this error when I am trying the 17th tutorial - Writing a Simple Publisher and Subscriber (C++)-

irem@willis:~$ cd ~/fuerte_workspace/sandbox/beginner_tutorials
irem@willis:~/fuerte_workspace/sandbox/beginner_tutorials$ make
mkdir -p bin
cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
[rosbuild] Building package beginner_tutorials
Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests beginner_tutorials
[rospack] Error: package/stack beginner_tutorials depends on non-existent package std_msgs


CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):


  Failed to invoke rospack to get compile flags for package
  'beginner_tutorials'.  Look above for errors from rospack itself.
  Aborting.  Please fix the broken dependency!

Call Stack (most recent call first):
  /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
  CMakeLists.txt:12 (rosbuild_init)


-- Configuring incomplete, errors occurred!
make: *** [all] Error 1**
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-06 01:45:18 -0600

mary gravatar image

It was.In the end I had to reinstall everything. It still did not work. I reinstalled ubuntu and ros again xD Still thanks for your response :)

edit flag offensive delete link more
1

answered 2013-08-02 03:22:54 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Is rospack package installed ? (check it out doing roscd rospack, if you have an error message, it is not installed)

If it isn't installed try to do 'sudo apt-get install ros-fuerte-rospack' to install it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-02 01:45:34 -0600

Seen: 376 times

Last updated: Aug 06 '13