Ask Your Question

Kinect not getting power from Irobot create base. is it openni problem??

asked 2013-07-22 22:23:12 -0600

FourTrees gravatar image

updated 2016-10-24 08:59:17 -0600

ngrennan gravatar image

now i use turtlebot(create). but kinect don't get power from Irobot create base. usb version is 2.0, and ubuntu 12.04 , ROS fuerte. Kinect is a red status light. is this problem openni problem?? if It is, please let me know what to do

If I operate openni.launch, the result is "[ INFO] [1375071903.030941613]: No devices connected.... waiting for devices to be connected"

and dashboard's result is

Node: /openni_driver Time: 1375071912.050908274 Severity: Info Location: /tmp/buildd/ros-fuerte-openni-camera-1.8.6/debian/ros-fuerte-openni-camera/opt/ros/fuerte/stacks/openni_camera/src/nodelets/driver.cpp:DriverNodelet::setupDevice:218 Published Topics: /rosout

No devices connected.... waiting for devices to be connected

what is the problem?? if you know that, please let me know.

thank you ^^

edit retag flag offensive close merge delete


I am having problem while connecting the kinect power using DB25 connector of Irobot create base. The connector circuit is designed by clearpath robotics to provide 12V DC power to kinect by taking power from pin 10 and 14 of DB25 connector of irobot create base.

lifelonglearner gravatar imagelifelonglearner ( 2013-07-25 23:51:44 -0600 )edit

2 Answers

Sort by » oldest newest most voted

answered 2013-07-28 18:40:02 -0600

lifelonglearner gravatar image

updated 2013-08-01 01:01:24 -0600

I am facing the same problem that kinect not getting power from Irobot create base.... However I am very much sure that it is not an openni problem.

I read to a tutorial by Prof. Jason O'Kane he says that : For the Kinect sensor to operate correctly, it must draw power from the Create’s battery. (The 5V available from the USB connection to the netbook is not sufficient; the Kinect needs at least 8V. Note that seeing blinking lights in the Kinect is, in my experience, not enough to know for sure that the Kinect is receiving the power it needs.) Your Turtlebot has a cable connecting the Kinect to the Create for this purpose, but by default that power supply is disabled. To enable it .........

**rosrun create_node**

I tried it but this was not working. The create base is connected to ttyACM0 port as the serial to USB connector definition. Then I checked the power supply of pin 10-11-12 of DB25 connector and found that the above command working well and I robot create giving power supply of 14V DC. So it is problem of 12V DC regulator circuit board. Which I will replace soon.

edit flag offensive delete link more


If you get to resolve the problem then please do let me too by posting the solution. Thanking you.

lifelonglearner gravatar imagelifelonglearner ( 2013-07-28 18:42:45 -0600 )edit

sure, I operated 'rosrun create_node'. but I don't solve it.\ if I know that, I will notice you

FourTrees gravatar imageFourTrees ( 2013-07-28 19:51:09 -0600 )edit

I sended mail about my question.

FourTrees gravatar imageFourTrees ( 2013-07-29 18:55:11 -0600 )edit

to whom you sent the e-mail?

lifelonglearner gravatar imagelifelonglearner ( 2013-07-29 18:57:28 -0600 )edit

turtlebot company -> iheartenginerring I attached contents below

FourTrees gravatar imageFourTrees ( 2013-07-29 18:59:41 -0600 )edit

I found this solution. My power cable(from create base to kinect) is wrong. +12v cable and ground cable connected incorrectly. Could you look at this part again????

FourTrees gravatar imageFourTrees ( 2013-07-30 21:18:16 -0600 )edit

is it working now? Please e-mail me the detail about the connector n circuit you are using and steps to run. mailID-

lifelonglearner gravatar imagelifelonglearner ( 2013-07-30 21:21:34 -0600 )edit

I sended e-mail to you ^^

FourTrees gravatar imageFourTrees ( 2013-08-02 00:34:55 -0600 )edit

answered 2013-07-29 18:57:59 -0600

FourTrees gravatar image

updated 2013-08-01 00:04:26 -0600

the cable connecting from create base to kinect is wrong.

I replace new cable and then kinect is operating ^^

edit flag offensive delete link more


it is the same script file ( that i told you earlier. this file is getting run through command
rosrun create_node
can you tell them that you had run this command but it does not worked

lifelonglearner gravatar imagelifelonglearner ( 2013-07-29 19:10:17 -0600 )edit

I also use **rosrun create_node** but it does not worked.. Do you have a multi-meter to test the voltage? and test the voltage??

FourTrees gravatar imageFourTrees ( 2013-07-29 19:15:12 -0600 )edit

yes i have let me test it but frankly speaking if the proper voltage is coming on port then the LED on the connector of kinect will glow well and will indicate that power is coming properly so no need to test it with multi-meter

lifelonglearner gravatar imagelifelonglearner ( 2013-07-29 19:16:31 -0600 )edit

could you ask them to get new answer??????????

lifelonglearner gravatar imagelifelonglearner ( 2013-07-30 01:25:25 -0600 )edit

no, I didn't receive reply. if I receive it, I'll tell you

FourTrees gravatar imageFourTrees ( 2013-07-30 01:37:19 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-07-22 22:23:12 -0600

Seen: 258 times

Last updated: Aug 01 '13