Ask Your Question
0

URDF tutorial probolem

asked 2013-07-19 02:18:00 -0600

VeryNewToROS gravatar image

updated 2013-07-19 03:43:37 -0600

allenh1 gravatar image

Dear Reader,

I have been trying to work through the tutorials URDF tutorials online and have had a problem with Rviz, It looks nothing like the tutorial's example and the are a few errors.

Screenshot

Any suggestions as to how to fix this would be greatly appreciated.

Thanks In Advance

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-07-19 02:26:31 -0600

BennyRe gravatar image

updated 2013-07-19 05:06:35 -0600

Try to set the fixed frame to /base_link or /world if it exists. Currently it is set to /map which does not exist.

As David Lu wrote in his comment expand the Global Options and double click on /map next to Fixed Frame. There you have to select /base_link. There should be no problem with the VM. The /map frame is the default for rviz, at least for me.

edit flag offensive delete link more
0

answered 2013-07-19 03:29:01 -0600

VeryNewToROS gravatar image

Thanks for your reply I suspected that was the causes but am not sure now to go about fixing it, I followed the tutorial to the letter, could this be something to do with me running it on a VM?

edit flag offensive delete link more

Comments

1

Please do not reply to answers with new answers, use comments instead, or edit your question. In the top left of Rviz, expand the Global Options widget and change the Global Frame to /base_link.

David Lu gravatar imageDavid Lu ( 2013-07-19 04:51:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-19 02:18:00 -0600

Seen: 165 times

Last updated: Jul 19 '13