Ask Your Question
2

roscd: command not found (in groovy 12.04)

asked 2013-07-09 05:15:59 -0500

jmainpri gravatar image

rosbash is installed but the following gives :

$ roscd
roscd: command not found

This initial command from the rosbash wiki page returns:

$ source ${ROS_ROOT}/tools/rosbash/rosbash
bash: /opt/ros/groovy/share/ros/tools/rosbash/rosbash: No such file or directory

The version of the package is :

$ dpkg -s ros-groovy-rosbash
Package: ros-groovy-rosbash
Status: install ok installed
Priority: extra
Section: misc
Installed-Size: 131
Maintainer: Dirk Thomas <dthomas@osrfoundation.org>
Architecture: amd64
Version: 1.9.45-0precise-20130325-0832-+0000
Depends: ros-groovy-catkin
Description: Assorted shell commands for using ros with bash.
Homepage: http://www.ros.org/wiki/rosbash
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
5

answered 2013-07-09 07:38:17 -0500

Dirk Thomas gravatar image

The comment on the rosbash wiki page was outdated. I have updated the wiki page.

The correct way is to source /opt/ros/DISTRONAME/setup.bash instead of the rosbash file. This will not only give you bash-specific completions but also the correct environment variable like ROS_ROOT, ROS_PACKAGE_PATH etc.

edit flag offensive delete link more

Comments

It doesn't work for me.

jmainpri gravatar imagejmainpri ( 2013-07-09 09:36:25 -0500 )edit
0

answered 2013-07-09 05:42:53 -0500

Lucile gravatar image

updated 2013-07-09 05:48:36 -0500

I looks like you didn't source ROS's setup.bash. Follow this tutorial to set it up : http://www.ros.org/wiki/groovy/Installation/Ubuntu#groovy.2BAC8-Installation.2BAC8-DebEnvironment.Environment_setup

This should solve your problem

(By the way it looks like /opt/ros/groovy/share/ros/tools/ folder doesn't exist, which may explain the error you got.)

edit flag offensive delete link more
-3

answered 2013-07-09 06:45:50 -0500

jmainpri gravatar image

updated 2013-07-09 09:49:59 -0500

No it appears to be a shipped bug... a dirty fix is to add :

source /opt/ros/groovy/share/rosbash/rosbash

after the usual source /opt/ros/groovy/setup.bash

edit flag offensive delete link more

Comments

4

This is not a bug and source /opt/ros/groovy/share/rosbash is not the right solution.

Dirk Thomas gravatar imageDirk Thomas ( 2013-07-09 07:39:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-09 05:15:59 -0500

Seen: 4,530 times

Last updated: Jul 09 '13