ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Groovy - Cannot find nodes in package

asked 2013-07-03 06:39:12 -0500

sterlingm gravatar image

updated 2014-01-28 17:02:47 -0500

ngrennan gravatar image

Hi, I just recently upgraded to groovy and cloned a catkinized version of a package from github. Whenever I run a launch file, ros tells me that it cannot find the nodes in the packages.

ERROR: cannot launch node of type [package_name/node_name]: can't locate node [node_name] in package [package_name]

The nodes should be in /devel/lib/package_name/ right? I have checked those directories and the executables are definitely there and correctly named.

My environment variables are the following:


~/ros_packages is my catkin workspace. I tried also adding ~/ros_packages into ROS_PACKAGE_PATH, but that didn't solve the problem.

Am I missing an environment variable? I checked and didn't think any would solve my problem. But I feel like the issue is either missing an environment variable, or not having one set properly to find the nodes in /devel/lib/package_name (if that directory is where they should be).

Any help is appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-03 07:51:55 -0500

updated 2013-07-03 07:54:41 -0500

You should source catkin_ws/devel/setup.bash or add it to your .bashrc file

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-07-03 06:39:12 -0500

Seen: 106 times

Last updated: Jul 03 '13