Ask Your Question
-1

Update Problem, Error: is not a package or launch file name

asked 2013-07-03 04:51:15 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi, everything was OK before I did update. After update of ROS packages the ROS Groovy not work or give me the following message:

[move_monsun] is not a package or launch file name when I use the lanch file

roslaunch move_monsun move_monsun.launch
<launch>
    <group ns="monsun"> 
      <node pkg="move_monsun" name="PID_Move" type="move_monsun_node" output="screen">
    <param name="k_p" value="1.0" type="double"/>
    <param name="k_i" value="0.0" />
    <param name="k_d" value="0.0" />
    <param name="k_pl" value="1.0" type="double"/>
    <param name="k_il" value="0.0" />
    <param name="k_dl" value="0.0" />
    <param name="i_max" value="0.0" />
    <param name="output_min" value="-60.0" />
    <param name="output_max" value="60.0" />
    <param name="output_minl" value="-40.0" />
    <param name="output_maxl" value="40.0" />
     </node>
    </group>
</launch>

I am sure, I don't make any change in path of ros_workspace. I am run for the same packages before the update and they work and after the update don't work. I'm sure I did not do to change anything in the my files only I've update for my ROS_packages. I tred rosmake agin for the same packges and I get the follwing:

[ rosmake ] rosmake starting...                                                                                                        
[ rosmake ] No package or stack specified.  And current directory 'move_monsun' is not a package name or stack name.                   
[ rosmake ] Packages requested are: []                                                                                                 
[ rosmake ] Logging to directory /home/amory/.ros/rosmake/rosmake_output-20130703-172136                                               
[ rosmake ] Expanded args [] to:
[]                                                                                                    
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

In my .bashrc there the path of ROS

source /opt/ros/groovy/setup.bash
export ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH
export ROS_WORKSPACE=~/ros_workspace

And roscd is working. Any ideas thanks

edit retag flag offensive close merge delete

Comments

Is it still not working ? Did you try to reinstall everything from scratch ?

Lucile gravatar imageLucile ( 2013-07-10 22:18:42 -0500 )edit

Yes, I install fresh ROS and I get the same problem.May be the problem in path of ROS but I written as above.

underwater gravatar imageunderwater ( 2013-07-11 01:57:24 -0500 )edit

Did you check rosdep version ? Command line is rosdep --version I had the same kind of problems as yours with a new ROS install and it apparently came from the fact that rosdep wasn't up to date.

Lucile gravatar imageLucile ( 2013-07-11 02:04:09 -0500 )edit

( 0.10.21 version)

underwater gravatar imageunderwater ( 2013-07-11 10:49:03 -0500 )edit

Ok, rosdep is ok then. But I do not think you have to add ROS_PACKAGE_PATH and ROS_WORKSPACE to your .bashrc since some other files are called from setup.bash to set them up. Plus, the path you set for ROS_PACKAGE_PATH seems wrong to me because it doesn't lead to stacks and share folders.

Lucile gravatar imageLucile ( 2013-07-11 22:03:38 -0500 )edit

My path ros_workspace is /home/amory/ros_workspace

underwater gravatar imageunderwater ( 2013-07-11 23:33:27 -0500 )edit

And in .bashrc is the follwing :source /opt/ros/groovy/setup.bash export ROS_WORKSPACE=~/ros_workspace export ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH. What is wrong ?

underwater gravatar imageunderwater ( 2013-07-11 23:36:14 -0500 )edit

My mistake. I mixed up ROS_PACKAGE_PATH and ROS_WORKSPACE. It doesn't seem to come from your path definition. Seems like your problem is somewhere deeper in your ROS system. Maybe some tool is broken ?

Lucile gravatar imageLucile ( 2013-07-12 03:16:34 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
3

answered 2013-07-04 08:13:17 -0500

gvdhoorn gravatar image

This could be related to ros-infrastructure/rospkg/issues/39.

edit flag offensive delete link more

Comments

I could confirm that. With the update my rosbuild package I had used make eclipse-project with broke launching and removing CATKIN_IGNORE helped.

felix k gravatar imagefelix k ( 2013-07-08 00:01:17 -0500 )edit
6

answered 2013-07-03 22:07:50 -0500

Asfandyar Ashraf Malik gravatar image

Taken from the wiki

For a package to be considered a catkin package it must meet a few requirements:

The package must contain a catkin compliant package.xml file
That package.xml file provides meta information about the package
The package must contain a CMakeLists.txt which uses catkin
The exception to this rule is that catkin metapackages do not have a CMakeLists.txt file
There can be no more than one package in each folder
This means no nested packages nor multiple packages sharing the same directory

I think you might be missing some files. I had a similar problem once and it was solved through this. Check if you have all these files and follow the following tutorial correctly

http://www.ros.org/wiki/ROS/Tutorials/CreatingPackage

If it still does not work, you might have to change the ROS_PACKAGE_PATH

edit flag offensive delete link more

Comments

Just to be clear: while certainly helpful in making sure the OP has the proper files for a catkin package, this particular error was caused by a problem in ros/mk and catkin. See ros/issues/20 for more information.

gvdhoorn gravatar imagegvdhoorn ( 2013-07-18 22:22:59 -0500 )edit
1

answered 2013-07-03 05:05:52 -0500

Sonne gravatar image

Hi,

what kind of build system do you use? If you use catkin, did you source the setup file?

Greetz Sonne

edit flag offensive delete link more

Comments

I use rosmake and ROS Groovy with Ubuntu 12.04 LTS and Ubuntu 13.04 and I get the same problem for both version of Ubunto

underwater gravatar imageunderwater ( 2013-07-03 05:07:34 -0500 )edit

Ok, I thought it could be the same problem like I have. But I use catkin. Have you tried to build your package again?

Sonne gravatar imageSonne ( 2013-07-03 05:12:22 -0500 )edit

I just have tred and I get the following :[ rosmake ] rosmake starting...
[ rosmake ] No package or stack specified. And current directory 'move_monsun' is not a package name or stack name.

underwater gravatar imageunderwater ( 2013-07-03 05:19:07 -0500 )edit
1

answered 2013-07-03 05:41:20 -0500

dornhege gravatar image

You need to include the move_monsun directory in the ROS_PACKAGE_PATH.

edit flag offensive delete link more

Comments

but move_monsun is a package where in the ros_workspace ~/ros_workspace/move_monsun

underwater gravatar imageunderwater ( 2013-07-03 10:08:25 -0500 )edit

is your ros_workspace still in ROS_PACKAGE_PATH ?

Lucile gravatar imageLucile ( 2013-07-03 22:26:10 -0500 )edit

yes, I am sure

underwater gravatar imageunderwater ( 2013-07-03 23:48:42 -0500 )edit

source /opt/ros/groovy/setup.bash
export ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH
export ROS_WORKSPACE=~/ros_workspace

underwater gravatar imageunderwater ( 2013-07-03 23:52:09 -0500 )edit

Are all you packages concerned by this problem ? I am dealing with a quite similar issue with a new ROS installation.

Lucile gravatar imageLucile ( 2013-07-08 23:14:40 -0500 )edit

Yes, all packages.

underwater gravatar imageunderwater ( 2013-07-09 03:38:19 -0500 )edit

Ok, then we might be struggling with the same troubles. I am trying to reinstall from scratch in order to understand what went wrong. I'll keep you up

Lucile gravatar imageLucile ( 2013-07-09 03:43:37 -0500 )edit

Ok, here's my question : http://answers.ros.org/question/66797/ros-installation-failed I finally got it working. I hope the answer will help you

Lucile gravatar imageLucile ( 2013-07-09 04:53:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-03 04:51:15 -0500

Seen: 1,956 times

Last updated: Jul 21 '13