Ask Your Question
0

rospack error(libboost_system_mt-1.48.so)

asked 2013-07-01 22:15:47 -0500

Oppenheim gravatar image

Hi, I'm trying to cross-compile Nao V4. But when I use rospack command, following error message comes out.

rospack: error while loading shared libraries: libboost_system-mt-1_48.so.1.48.0: cannot open shared object file: No such file or directory

I tried installing library files by "$ sudo apt-get install libboost-system libboost-dev etc. But nothing has been solved.

In fact, I found out this error when I tried to source $TARGETDIR/workspace_nao/setup.bash, which contained "rospack" command. This content came from http://www.ros.org/wiki/nao/Tutorials/Cross-Compiling_NAO-V4#Creating_a_workspacehttp:// (tutorial). When I tried to source setup.bash, following error message came out.

rospack could not be found, you cannot have rosbash features until you bootstrap ros

So I think that it is the error coming from rospack error related with library(libboost?).

Is there Anyone who knows the solution?

Thanks in advance! :)

edit retag flag offensive close merge delete

Comments

Actually, I'm using ubuntu 10.04 now, but I'm not sure why libboost1.48 is needed..

Oppenheim gravatar image Oppenheim  ( 2013-07-02 23:45:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-08-12 10:25:20 -0500

tfoote gravatar image

If you have switched Ubuntu versions you need to make sure to clean all build artifacts. Likely you have either a CMakeCache or simply libraries which were linked on the other OS and now cannot be loaded because there's a different version of boost installed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-01 22:15:47 -0500

Seen: 187 times

Last updated: Aug 12 '13