ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

teleop_base compile error with finding joy package [closed]

asked 2013-06-27 04:37:56 -0500

dalishi gravatar image

updated 2013-06-29 10:31:47 -0500

allenh1 gravatar image

Dear all, i try to build the teleop_base for the stage for groovy as in the tutorial but got errors finding the package joy which i am sure i have compiled and installed (tried both from source and binary), any thoughts about this error? thanks.

 [rosbuild] Cached build flags older than manifests; calling rospack to get flags
 Failed to invoke /home/techx/ros_catkin_ws/install_isolated/bin/rospack cflags-  only-I;--deps-only teleop_base
 Package joy was not found in the pkg-config search path.
 Perhaps you should add the directory containing `joy.pc' to the PKG_CONFIG_PATH environment variable
 No package 'joy' found
 [rospack] Error: python function 'rosdep2.rospack.call_pkg_config' could not call 'pkg-config --cflags-only-I joy' without errors

CMake Error at /home/techx/ros_catkin_ws/install_isolated/share/ros/core/rosbuild/public.cmake:129 (message):

Failed to invoke rospack to get compile flags for package 'teleop_base'.
Look above for errors from rospack itself.  Aborting.  Please fix the
broken dependency!

Hi allenh, thanks, but this doesnot solve my problem. I succeeded in installing the packages using the command you posted, however, the error remains when i rosmake teleop_base.

[rospack] Error: package/stack 'teleop_base' depends on non-existent package 'joy' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update'

I also tried to install joystick_drivers: joy from source, but $ rosdep install joy and $ rosmake joy do not work. The result is like

No Makefile in package diagnostic_updater [rosmake-0] Starting >>> joy [ make ] [rosmake-0] Finished <<< joy ROS_NOBUILD in package joy No Makefile in package joy

the package.xml in the joystick_drivers/joy folder is

<description> ROS driver for a generic Linux joystick. The joy package contains joy_node, a node that interfaces a generic Linux joystick to ROS. This node publishes a "Joy" message, which contains the current state of each one of the joystick's buttons and axes. </description> <maintainer email="">Jonathan Bohren</maintainer> <author>Morgan Quigley</author> <author>Brian Gerkey</author> <author>Kevin Watts</author> <author>Blaise Gassend</author> <url type="website"></url> <url type="development"></url> <url type="bugtracker"></url><buildtool_depend>catkin</buildtool_depend><build_depend>roscpp</build_depend><build_depend>diagnostic_updater</build_depend><build_depend>sensor_msgs</build_depend><build_depend>joystick</build_depend><run_depend>roscpp</run_depend><run_depend>diagnostic_updater</run_depend><run_depend>sensor_msgs</run_depend><run_depend>joystick</run_depend><test_depend>rosbag</test_depend><export><rosbag migration_rule_file="migration_rules/Joy.bmr"/><architecture_independent/></export></package>
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-28 16:19:35.762188

1 Answer

Sort by ยป oldest newest most voted

answered 2013-06-28 11:18:21 -0500

allenh1 gravatar image

You need to install the joystick drivers.

sudo apt-get install ros-groovy-pr2-controllers ros-groovy-joystick-drivers

Assuming you are on ubuntu. If you have the aforementioned packages installed on your system, please post the package.xml file and some more information about what you are trying to accomplish.

edit flag offensive delete link more


Hi allenh, thanks, but this doesnot solve my problem. I succeeded install the packages using the command you posted, however, the error remains.

dalishi gravatar image dalishi  ( 2013-06-29 03:25:57 -0500 )edit

Question Tools


Asked: 2013-06-27 04:37:56 -0500

Seen: 1,348 times

Last updated: Jun 29 '13