Ask Your Question
1

Android AppChooser connection fails

asked 2013-06-24 20:53:56 -0500

Johannes Mayr gravatar image

Hello, I installed the OSRF AppChooser on my android tablet and started the roscore on my robots computer (sample IP 123.456.789.123). Then I tried to connect from the AppChooser to the computer by using its IP adress in the above format. Doing so, the tablet can't connect and I get an error underneath the button for the robot that says: "java.lang.ClassCastException:java.lang.Integer canno be cast to java.lang.String". As I can't find my computer in the network by its domain name using the computer name instead of the IP gives the error "java.lang.RuntimeExcption: java.net.UnknownHostException: Unable to resolve host "....": No address associated with hostname". How do I have to enter a IP adress so that the AppChooser can connect to the robot's computer? The connection itself is working as I can connect to the roscore without troubles from Rviz for Android. There I use the same IP and port and everything works fine.

Best Wishes Johannes

edit retag flag offensive close merge delete

Comments

I'm having the exact same problem, what tablet do you have? I have a Nexus 10, and no other android devices to test it on at the moment.

Jonathan K. gravatar image Jonathan K.  ( 2013-07-02 08:05:34 -0500 )edit

I'm having a Galaxy 10 tablet. But I do have the same problems with my GalaysS Phone. I do not think that this issue is related to the tablet itself. To me it looks like a domain name table problem which I do not know how to solve without rooting the tablet (which is not possible)

Johannes Mayr gravatar image Johannes Mayr  ( 2013-07-03 21:42:51 -0500 )edit

Did anyone find out how to solve this problem? I've tried IP address, DNS, different formats and all end up with issues as mentioned

MarkyMark2012 gravatar image MarkyMark2012  ( 2014-03-19 09:57:26 -0500 )edit

Hi,

did anybody solved this issue. The ROS groovy AppChosser (from Play Store) running on my Android seems not be able to connect to my roscore. Its shows "Unknown http://192.168.1.48:11311/ java.lang.ClassCastException: java.lang.integer: cannot cast to java.lang.string".

Any hint?

Maik gravatar image Maik  ( 2014-12-27 07:37:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-28 01:22:51 -0500

Johannes Mayr gravatar image

Is it possible that I can only connect via a fully qualified domain name? If so, how can I set the hosts file on a tablet without root access? I think thats not possible and the only solution is to add my IP an a DNS server?

Thanks Johannes

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-24 20:53:56 -0500

Seen: 1,146 times

Last updated: Jun 28 '13