RGBDSLAM with RosBag Files does not work. [closed]

asked 2013-05-27 01:25:23 -0600

preetham.hegde gravatar image

updated 2014-01-28 17:16:39 -0600

ngrennan gravatar image

Hello all, I am new to ROS and i am trying to use the RGBDSLAM with ROSbag files i.e i want to first run the rosbag record and make a rosbag file and then run RGBD SLAM such that it will read this rosbag file and give me a map.

I found another post on the similar issue and used the launch file he used i.e

<launch>
  <node pkg="rgbdslam" type="rgbdslam" name="rgbdslam" cwd="node" required="false" output="log" > 
    <!-- see rgbslam_sample_config.launch for all available parameters and their default values -->
      <param name="config/topic_image_mono"              value="/camera/rgb/image_color"/>

<param name="config/topic_image_depth"             value="/camera/depth_registered/image"/>
<param name="config/topic_points"                  value=""/> <!--if empty, poincloud will be reconstructed from image and depth -->
<param name="config/camera_info_topic"             value="/camera/rgb/camera_info"/>
<param name="config/bagfile_name"                  value="/home/preetham/Desktop/filename.bag"/>
<param name="config/start_paused"                  value="true"/>

      <param name="config/wide_topic"                    value=""/>;
      <param name="config/wide_cloud_topic"              value=""/>;
      <param name="config/drop_async_frames"             value="true"/> <!-- Check association of depth and visual image, reject if not in sync -->
      <param name="config/feature_detector_type"         value="SURF"/><!-- If SIFTGPU is enabled in CMakeLists.txt, use SURF here -->
      <param name="config/feature_extractor_type"        value="SURF"/><!-- If SIFTGPU is enabled in CMakeLists.txt, use SURF here -->
      <param name="config/matcher_type"                  value="FLANN"/> <!-- FLANN (not avail for ORB features), SIFTGPU (only for SIFTGPU detector)  or BRUTEFORCE-->
      <param name="config/max_keypoints"                 value="2000"/><!-- Extract no more than this many keypoints (not honored by SIFTGPU)-->
      <param name="config/min_keypoints"                 value="1600"/><!-- Extract no less than this many ... -->
      <param name="config/optimizer_skip_step"           value="5"/><!-- optimize every n-th frame -->
      <param name="config/store_pointclouds"             value="true"/> <!-- if, e.g., only trajectory is required, setting this to false saves lots of memory -->
      <param name="config/individual_cloud_out_topic"    value="/rgbdslam/batch_clouds"/>;
      <param name="/config/use_gui" value="true"/>
    <!-- see rgbslam_sample_config.launch for all available parameters and their default values -->

<remap from="/camera/depth/camera_info" to="/camera/depth_registered/camera_info" />

  </node>
</launch>

And when i launch RGBDSLAM using this launch file it throws an error.

The following is the rosbag command i used and it records a rosbag file of size 300 Mb for 10 seconds which i feel is correct.

rosbag record -o /home/preetham/Desktop/filename_prefix /tf /camera/rgb/image_color /camera/rgb/camera_info /camera/depth_registered/image /camera/depth/camera_info

ould somebody help me out??

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-11-14 11:32:26

Comments

What is the error you get? Are you sure you have the correct filename? Does the GUI appear? Have you tried pressing space to start processing?

Felix Endres gravatar imageFelix Endres ( 2013-05-31 02:33:38 -0600 )edit