Ask Your Question
0

Roomba 560 "Could not connect to Roomba" Error in ROS (Ubuntu 12.04)

asked 2013-05-26 15:57:41 -0500

robbie.sharma gravatar image

updated 2013-11-14 11:32:44 -0500

tfoote gravatar image

I've built an SCI-RS-232-USB cable for connecting to my Roomba using the following tutorial:

blog.makezine.com/2008/02/29/how-to-make-a-roomba-seri/

The cable works as I tested it on my Windows machine using the RealTerm Serial Terminal. I was able to make the roomba move and beep by sending raw opcodes. However it should be noted, I could only send packets if the RTS line was cleared, and only receive sensor packets if the RTS line was set.

I've tried to change the hardware and software control options in minicom to try to get a different response; no luck. Basic troubleshooting - disconnecting, power cycling, etc.

Any help to remedy the problem is appreciated!

Here is the necessary info from the USB-Serial interface

USB-Serial Permissions

dmesg | grep tty

[    1.113447] tty tty34: hash matches
[ 1142.333506] usb 2-1: FTDI USB Serial Device converter now attached to ttyUSB0

ls -l /dev/ttyUSB0
crwxrwxrwx 1 root dialout 188, 0 May 26 18:19 /dev/ttyUSB0

Minicom configuration

A -    Serial Device      : /dev/ttyUSB0                              |
    | B - Lockfile Location     : /var/lock                                 |
    | C -   Callin Program      :                                           |
    | D -  Callout Program      :                                           |
    | E -    Bps/Par/Bits       : 115200 8N1                                |
    | F - Hardware Flow Control : No                                        |
    | G - Software Flow Control : No

Rosrun Error

    rosrun roomba_500_series roomba500_light_node

    [ INFO] [1369617555.945517395]: Roomba for ROS 2.01
    [FATAL] [1369617555.969045803]: Could not connect to Roomba.
    [FATAL] [1369617555.969251975]: BREAKPOINT HIT
        file = /home/trevor/catkin_ws/trunk/roomba_500_series/src/roomba500_lightweight.cpp
        line=90

Trace/breakpoint trap (core dumped)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-07 14:38:27 -0500

TimboInSpace gravatar image

Try enabling hardware flow control. That should raise and lower the RTS pin for you from minicom. Let me know your results, I'm working on the same problem and have so far had no luck connecting to the roomba...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-05-26 15:57:41 -0500

Seen: 613 times

Last updated: Apr 07 '15