Ask Your Question
1

OpenNI: Camera calibration file not found.

asked 2013-05-20 21:28:11 -0600

liborw gravatar image

updated 2013-05-23 01:21:22 -0600

Hi,

I have calibration file for both RGB and IR camera. However, i'm still getting the Camera calibration file xxx not found. even though the xxx is the correct path?

Full console output:

Initializing nodelet with 4 worker threads.

Loading nodelet /xtion2/rgb/rectify_color of type image_proc/rectify to manager /xtion2_nodelet_manager with the following remappings:

Loading nodelet /xtion2/rgb/rectify_mono of type image_proc/rectify to manager /xtion2_nodelet_manager with the following remappings:

Initializing nodelet with 4 worker threads.

Loading nodelet /xtion2/rgb/debayer of type image_proc/debayer to manager /xtion2_nodelet_manager with the following remappings:

Loading nodelet /xtion2/ir/rectify_ir of type image_proc/rectify to manager /xtion2_nodelet_manager with the following remappings:

Loading nodelet /xtion2/depth/metric of type depth_image_proc/convert_metric to manager /xtion2_nodelet_manager with the following remappings:

Loading nodelet /xtion2/depth/rectify_depth of type image_proc/rectify to manager /xtion2_nodelet_manager with the following remappings:

Loading nodelet /xtion2/depth/metric_rect of type depth_image_proc/convert_metric to manager /xtion2_nodelet_manager with the following remappings:

/xtion2/depth/image_rect -> /xtion2/depth/image_rect_raw

/xtion2/depth_registered/image_mono -> /xtion2/depth_registered/image_raw

/xtion2/depth/camera_info -> /xtion2/depth/camera_info

/xtion2/depth_registered/image_rect -> /xtion2/depth_registered/image_rect_raw

/xtion2/depth_registered/image_raw -> /xtion2/depth_registered/image_rect_raw

Loading nodelet /xtion2/depth_registered/metric of type depth_image_proc/convert_metric to manager /xtion2_nodelet_manager with the following remappings:

Number devices connected: 2

1. device on bus 001:03 is a PrimeSense Device (600) from PrimeSense (1d27) with serial id ''

2. device on bus 002:03 is a PrimeSense Device (601) from PrimeSense (1d27) with serial id ''

Searching for device with bus@address = 2@0

/xtion2/right -> /xtion2/projector

/xtion2/left/image_rect -> /xtion2/depth_registered/image_rect_raw

Opened 'PrimeSense Device' on bus 2:3 with serial number ''

Could not find any compatible image output mode for 1280 x 1024 @ 15. Falling back to default image output mode 1280 x 1024 @ 30.

rgb_frame_id = '/xtion2_rgb_optical_frame' 

depth_frame_id = '/xtion2_depth_optical_frame' 

Camera calibration file /home/ros/.ros/clopema_calibration/xtion2/camera_rgb.yaml not found.

Using default parameters for RGB camera calibration.

Camera calibration file /home/ros/.ros/clopema_calibration/xtion2/camera_ir.yaml not found.

Tried to advertise a service that is already advertised in this node [/xtion2/depth_registered/image_rect_raw/compressedDepth/set_parameters]

Tried to advertise a service that is already advertised in this node [/xtion2/depth_registered/image_rect_raw/compressed/set_parameters]

Tried to advertise a service that is already advertised in this node [/xtion2/depth_registered/image_rect_raw/theora/set_parameters]

Output of the ls command:

$ ls /home/ros/.ros/clopema_calibration/xtion2/
camera_ir.yaml  camera_rgb.yaml  capture  report
edit retag flag offensive close merge delete

Comments

Please copy paste the full console output. Bests regards

Stephane.M gravatar imageStephane.M ( 2013-05-21 01:03:43 -0600 )edit

@Stephane.M I have updated the question.

liborw gravatar imageliborw ( 2013-05-22 22:25:10 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2013-05-29 02:45:18 -0600

liborw gravatar image

updated 2013-05-29 02:45:48 -0600

The Camera calibration file XXX not found. error message is misleading. The same message is show when the parsing fails. The file was there, but not properly formatted. I have submit an issue issue.

edit flag offensive delete link more

Comments

could you tell me how to solve the problem "Camera calibration file XXX not found"?

Mrs Wang gravatar imageMrs Wang ( 2013-06-05 04:53:06 -0600 )edit

You should never ask a question as an answer to another question. However, please not that the "error" Camera calibration file not found is not a problem, as default camera calibrations files exist, and programs work without further calibrations from users.

Stephane.M gravatar imageStephane.M ( 2013-06-05 23:56:49 -0600 )edit
1

answered 2013-05-22 23:07:36 -0600

(I post as an answer, as comments are too short. I will edit this during the resolution.)

Ok, from what I see in your copy-past, there is no problem... The calibration files have not been found, but instead it uses the default ones. can you do the following command in a terminal and gives use the output :

"ls /home/ros/.ros/clopema_calibration/xtion2/ "

Bests regards.

edit flag offensive delete link more

Comments

I have posted an update.

liborw gravatar imageliborw ( 2013-05-23 01:21:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-20 21:28:11 -0600

Seen: 5,915 times

Last updated: Jun 05 '13