Ask Your Question
0

can't run catkin_make on ros-fuerte

asked 2013-05-17 03:49:23 -0500

cupuyc gravatar image

I have installed ros-fuerte. The package 'ros-fuerte-catkin' is installed. But I cannot build my application using catkin_make:

source /opt/ros/fuerte/setup.bash
source /usr/share/drcsim/setup.sh
catkin_make: command not found

when I'm trying to install:

sudo apt-get install ros-fuerte-catkin
Reading package lists... Done
Building dependency tree
Reading state information... Done
ros-fuerte-catkin is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
edit retag flag offensive close merge delete

Comments

I'm not familiar with catkin on Fuerte, but the wiki says:

Boris gravatar image Boris  ( 2013-05-17 04:59:41 -0500 )edit
1

Note for ROS Fuerte Users: An experimental version of catkin was released with ROS Fuerte that is quite different from the version in Groovy. Those using ROS Fuerte should continue utilizing rosbuild.

Boris gravatar image Boris  ( 2013-05-17 04:59:58 -0500 )edit

So it may not has this functionality at all, i.e. catkin_make.

Boris gravatar image Boris  ( 2013-05-17 05:01:02 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
5

answered 2013-05-17 05:36:26 -0500

Hansg91 gravatar image

If I recall correctly, Fuerte did not yet have catkin, therefore catkin_make does not work. Try rosmake, assuming you have rospackages.

edit flag offensive delete link more

Comments

2

Fuerte had an early version of catkin, but I don't think catkin_make was available.

joq gravatar image joq  ( 2013-05-19 14:06:06 -0500 )edit
0

answered 2013-05-17 05:43:04 -0500

cupuyc gravatar image

So, I can't build my package anyway. I created a folder in home directory with the following files: "CMakeLists.txt, main.cpp, Makefile, manifest.xml" corresponding the rosbuild tutorial. After that I'm trying to make and obtain:

CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/private.cmake:99 (message):
  [rosbuild] rospack found package "src" at "", but the current directory is
  "/home/max/dev/test1/src".  You should double-check your ROS_PACKAGE_PATH
  to ensure that packages are found in the correct precedence order.

WTH? Why can't I build a package within the home directory? Is it necessary to copy the package to the rosbuild directory?

edit flag offensive delete link more

Comments

1

Please do not use "Your answer" form for discussions. This is not a forum, but Q&A site. So please create a separate question regarding your problems with a tutorial.

Boris gravatar image Boris  ( 2013-05-17 05:57:17 -0500 )edit
1

You should edit your original question or open a new one, but any rosbuild packages must be in the ROS_PACKAGE_PATH before building them.

William gravatar image William  ( 2013-05-17 07:14:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-17 03:49:23 -0500

Seen: 1,359 times

Last updated: May 17 '13