Ask Your Question
0

Suppressing wheel joint errors when using MoveIt!

asked 2013-05-13 05:20:41 -0500

Pi Robot gravatar image

Hello,

I am trying out the most excellent newly-released MoveIt! package under ROS Groovy, Ubuntu 12.04 and using a custom robot (Pi Robot) that has a TurtleBot arm attached. The MoveIt! setup assistant worked perfectly and I can run the demo.launch file and play with planning in RViz.

Next, I followed this tutorial to customize the MoveIt! configuration for my robot's servo controller (arbotix_python). Thanks to the tutorial, I can now move my robot's arm using the MoveIt! API. However, in the terminal in which I launch the MoveIt! launch and config files, I get a continual stream of errors of the form:

[ERROR] [1368457768.338308598]: Joint 'base_l_wheel_joint' not found in model 'pi_robot'
[ERROR] [1368457768.338451609]: Joint 'base_r_wheel_joint' not found in model 'pi_robot'

It is true that I don't have wheel joints in my URDF model, but is there any way to tell MoveIt! this so it doesn't complain?

Thanks!
patrick

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-15 10:28:46 -0500

Sachin Chitta gravatar image

Hey Patrick,

Thanks for trying out MoveIt! Glad to see it (mostly) worked for you :-)

I am trying to figure out what your situation is exactly -

(1) You have these joints defined in the URDF but are not publishing joint states for them? (2) You don't have these joints defined in the URDF and are publishing joint state for them

If these joints are "passive", e.g. an un-actuated caster, you can actually set them to be passive in the SRDF and then moveit won't complain about them. Otherwise, i.e. if they are actuated, you should have them in your URDF the right way.

edit flag offensive delete link more

Comments

Thanks @Sachin Chitta. It was more like (2) I did not have the joints in my URDF but I don't think I was publishing joint state for them either. In any event, I have added wheel joints to my URDF and made them passive like you suggested and everything works fine know.

Pi Robot gravatar imagePi Robot ( 2013-05-15 12:44:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-13 05:20:41 -0500

Seen: 647 times

Last updated: May 15 '13