Ask Your Question
0

problem with ROS NXT

asked 2013-05-04 15:53:05 -0500

emvela gravatar image

updated 2014-04-20 14:06:44 -0500

ngrennan gravatar image

Hi, my name is Edgar and I'm new in ROS. The problem is when I send sudo apt-get install ros-diamondback-nxtall and also with electric version, terminal shows this message:

*Reading package lists... Done Building dependency tree
Reading state information... Done

E: Unable to locate package ros-diamondback-nxtall*

How do I solve this. I have Ubuntu 12.10 and ROS groovy installed

edit retag flag offensive close merge delete

Comments

Hi Edgar: My name is Ivan,our robotics group is writing some packages to NXT for Groovy version. When it is available if you want to notice you.

Ivan Rojas Jofre gravatar image Ivan Rojas Jofre  ( 2013-05-08 06:52:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-06 03:23:28 -0500

ipso gravatar image

updated 2013-05-06 03:45:08 -0500

According to REP 003, Diamondback was never released for Ubuntu 12.10, so you can't install the NXT stack on your Ubuntu version.

According to wiki/nxt, the NXT stack is currently only build for Electric.

I see two options:

  1. go back to an Ubuntu version where Electric can be installed: most recent version would be Oneiric (11.10), according to REP 003.
  2. check out the sources for the NXT stack and try to build it for Fuerte or Groovy. AFAIK the NXT stack hasn't really been maintained, so this might be rather difficult.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-04 15:53:05 -0500

Seen: 179 times

Last updated: May 06 '13