Ask Your Question
1

rosjava groovy install help

asked 2013-04-29 14:41:13 -0500

HenryW gravatar image

updated 2013-11-14 11:16:32 -0500

tfoote gravatar image

Hey all

Am looking to install ROS java and have been going through the external documentation here http://docs.rosjava.googlecode.com/hg/rosjava_core/html/installing.html

However it is for older versions of ROS that do not use catkin. Is there anything different I need to do in order to correctly install ROSJava into my catkin workspace?

Also "rosws merge http://rosjava.googlecode.com/hg/.rosinstall" is giving me a 404 error and using the links from "https://github.com/rosjava/rosjava_core" are giving me a 406 Not acceptable error.

Any help from someone who has installed ROSJava on Groovy?

Cheers

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-04-29 16:10:51 -0500

130s gravatar image

rosjava has just been catkinized in source repo, although I haven't tried it out. You may want to try it out and feedback should be appreciated.

edit flag offensive delete link more

Comments

ahh excellent, thank you! Will experiment with it today and will give feedback when I can :D Thanks heaps

HenryW gravatar image HenryW  ( 2013-04-29 16:25:57 -0500 )edit

Ok, have downloaded and have rosjava_core in "~/catkin_ws/src/rosjava_core".

Running catkin_make in "~/catkin_ws" however is giving build error "Execution failed for task ':rosjava_test:compileJava'? Can't find a solution, but appears to have been reported at least previosuly

HenryW gravatar image HenryW  ( 2013-04-29 16:46:11 -0500 )edit

Feedback so far: When running either "catkin_make" or "./gradlew install" rosjava is unable to find rosjava_test package. I put a report on the git stie here https://github.com/rosjava/rosjava_core/issues/156

HenryW gravatar image HenryW  ( 2013-04-30 16:49:42 -0500 )edit

Can you roscd to test_ros? Is it in your ROS_PACKAGE_PATH?

damonkohler gravatar image damonkohler  ( 2013-05-07 21:08:43 -0500 )edit

will test that tomorrow, I know I can roscd in rosjava_core quite happily. The test_ros "pakcage" is stored within a subdirectory of rosjava_core. Would assume it would be able to see it, but will check tomorrow, cause you are probably right

HenryW gravatar image HenryW  ( 2013-05-08 18:45:16 -0500 )edit

@HenryW I know this is a year later, but did you have any success? I'm also trying to use rosjava with Groovy and am hitting the `package test_ros does not exist` error when I try to build. edit: NVM, using wstool then building worked, strange..

mbforbes gravatar image mbforbes  ( 2014-05-01 19:01:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-29 14:41:13 -0500

Seen: 582 times

Last updated: Apr 29 '13