Ask Your Question

Problem with roscore

asked 2013-04-09 22:22:03 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello. I have problem with roscore. When I try to run roscore I give this error:

Traceback (most recent call last): File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/", line 230, in main write_pid_file(options.pid_fn, options.core, options.port) File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/", line 106, in write_pid_file with open(pid_fn, "w") as f: IOError: [Errno 13] Permission denied: '/home/user/.ros/'

Does someone know how I can fix it ?

edit retag flag offensive close merge delete


If you have source /root/catkin_ws/devel/setup.bash in your .bashrc remove it, create the catkin workspace again and check.

prasanna.kumar gravatar image prasanna.kumar  ( 2013-04-09 22:49:39 -0600 )edit

It still doesn't work. I deleted my existing workspace, source from .bashrc and create new ones still appears this error. Maybe someone else know how fix this problem. I reinstall whole ROS and still nothing. I'm begginer in ROS.

Roboticus gravatar image Roboticus  ( 2013-04-09 23:16:57 -0600 )edit

Something is setup wrong. You can't write to the .ros directory or that specific file. What do you get for id -a, ls -la .ros?

dornhege gravatar image dornhege  ( 2013-04-10 00:53:18 -0600 )edit

2 Answers

Sort by » oldest newest most voted

answered 2015-02-12 11:58:15 -0600

Timo gravatar image

Hey guys, the problem could be that you ran rosdep update with sudo rights. That leads to permission errors later on.

NOTE : Run rosdep update NOT with sudo.

SOLUTION to fix this run sudo rosdep fix-permissions

and after that rosdep update.

Worked for me.



edit flag offensive delete link more


Perfect it does the trick for me. I was running programs from 'ROS by Example for Hydro - Volume 1'. I was not able to execute $ roslaunch rbx1_bringup fake_turtlebot.launch or $ roslaunch rbx1_bringup fake_pi_robot.launch

I would get 'IOERROR [Error13] ...'. Anyhow it is fixed now. Thanks!

imAsim gravatar image imAsim  ( 2015-03-17 20:09:33 -0600 )edit

the rosdep fix-permissions command worked for me!

luc gravatar image luc  ( 2015-09-08 12:55:20 -0600 )edit

Worked like a charm...

kjerath gravatar image kjerath  ( 2015-11-10 13:54:31 -0600 )edit

Awesome ,it worked.. than q @imAsim

Vijay gravatar image Vijay  ( 2016-02-16 15:43:16 -0600 )edit

answered 2013-04-10 04:31:55 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I had a similar problem running roscore. The problem was that the hidden folder " ~/.ros" required root rights.

To solve it, I deleted the folder with:

sudo su
rm -R ~/.ros/

After that, roscore worked well and a new .ros folder was created automatically.

edit flag offensive delete link more


If .ros required root rights, something was wrong before. Maybe some sudo call. ROS doesn't set the up as root.

dornhege gravatar image dornhege  ( 2013-04-10 07:16:35 -0600 )edit

Yes, there was a mistake in the groovy installation documentation, saying to run the command <rosdep update> with sudo. This leads to the error. The documentation is corrected now.

MachR gravatar image MachR  ( 2013-04-10 20:54:42 -0600 )edit

It doesn't work. When I entered the two command lines "rm: cannot remove ‘/root/.ros/’: No such file or directory" showed up. What is the problem?

zurish gravatar image zurish  ( 2015-02-11 13:55:28 -0600 )edit

You are in the home of the root user, not in the home of the user, where you want to remove the .ros directory.

dornhege gravatar image dornhege  ( 2015-02-12 03:16:23 -0600 )edit

@dornhege Thanks it's working now.

zurish gravatar image zurish  ( 2015-02-12 09:58:38 -0600 )edit

Worked like charm. But could you please explain what .ros contains? I thought it only stored the logs.

Joy16 gravatar image Joy16  ( 2017-04-10 18:59:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-04-09 22:22:03 -0600

Seen: 9,406 times

Last updated: Apr 10 '13