husky_navigation problem [closed]

asked 2013-04-09 21:44:34 -0600

Tirgo gravatar image

updated 2014-01-28 17:16:07 -0600

ngrennan gravatar image


i have a problem to let the husky plattform navigate autonomously through a given map. The major problem is that whenever the robot executes a rotation around the z-axis, the motion gets recognized,but in the wrong direction. You can see the motion of the robot in rviz even the value of the yaw angle chance looks fine, but the direction of this chance is wrong.

Everything else is working fine (laserscan, teleop, no warnings or error messages, etc.), even the path planning looks ok in rviz. But if the robot tries to execute a little rotation everything chrashes. It's like the system tries to compensates the error of the wrong direction and it's getting even worse, till the point that there is "no path available".

I'm using ubuntu 12.04 and ros-fuerte. I tried it with and without an imu with the same result. I'm not sure where i should start to search for the error, maybe someone had an issue similar to mine?

Thx for your answers.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-12-12 01:20:31.083294