ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

RQT not showing icons in OSX

asked 2013-04-04 09:12:35 -0500

Markus Achtelik gravatar image

updated 2013-04-04 09:14:39 -0500

Hi,

I just upgraded to the latest releases of rqt as announced on the mailing list earlier today, hoping this would help. rqt does not show icons for the plugins, e.g. the "refresh" or "help" icon under osx 10.8. It looks worst for rqt_bag, which is somewhat unusable in this state, as shown in the screenshot. Any ideas what that could be?screenshot

Thanks a lot!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2013-04-04 09:42:30 -0500

William gravatar image

updated 2013-04-04 10:47:45 -0500

rqt uses the tango-icon-theme for the icons. This package is available on ubuntu, but is not available through Homebrew (yet).

For now the dependency is left unresolved:

https://github.com/ros/rosdistro/blob/master/rosdep/osx-homebrew.yaml#L381

rqt (specifically rqt_bag in this case) might better handle this by falling back to system icons, but this may not be possible.

As a work around you can download, build and install the tango-icon-theme from source:

http://tango.freedesktop.org/releases/tango-icon-theme-0.8.90.tar.gz

By following the instructions here:

http://tango.freedesktop.org/Installation#Tango_Icon_Theme

This should allow rqt to show the icons, but I have never tried it myself.

EDIT:

I have created the required tango-icon-theme and icon-naming-utils formulae:

https://github.com/ros/homebrew-groovy/blob/master/icon-naming-utils.rb https://github.com/ros/homebrew-groovy/blob/master/tango-icon-theme.rb

If you already have the ros/groovy tap, then just do brew update, otherwise do brew tap ros/groovy.

I updated the rosdep entry, so now the tango-icon-theme should get installed automatically when following the source installation instructions:

https://github.com/ros/rosdistro/commit/9b35f250af19b253f278bfdb45af32fe961a32d1

Then I had to patch qt_gui_core to include /usr/local/share/icons to the icon search path for rqt:

https://github.com/ros-visualization/qt_gui_core/pull/17

So if you install tango-icon-theme and apply that patch to qt_gui_core then you get something like this:

rqt_bag

So there seems to be some other problem related to button positioning in rqt_bag.

I have opened an issue:

https://github.com/ros-visualization/rqt_common_plugins/issues/68

edit flag offensive delete link more

Comments

This is awesome, thanks a lot !! Will try it tomorrow morning, it's fairly late here already

Markus Achtelik gravatar imageMarkus Achtelik ( 2013-04-04 11:42:38 -0500 )edit

The steps above helped, thanks a lot again! For rqt_bag, I get the same behaviour as shown above by William, which is already a lot nicer than before.

Markus Achtelik gravatar imageMarkus Achtelik ( 2013-04-05 06:37:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-04 09:12:35 -0500

Seen: 328 times

Last updated: Apr 04 '13