Ask Your Question
0

android tutorial pubsub problem

asked 2013-03-29 06:33:22 -0500

Gosu gravatar image

updated 2013-03-30 02:46:10 -0500

Hi, I have installed the pubsub android tutorial on an android device and have it connect to an external roscore on ubuntu desktop.
When I run rostopic list on ubuntu desktop, the "chatter" topic is listed. But when I publish data on this topic, the rosTextView on android unchange. However, run rostopic echo /chatter display the data I published.

Would you know how to fix this?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-07 20:59:12 -0500

damonkohler gravatar image

Check that your NodeConfiguration is using a public address and that the master URI is correct. Also check ROS_IP and ROS_MASTER_URI on your desktop machine.

edit flag offensive delete link more

Comments

Thanks alot! Its worked

Gosu gravatar image Gosu  ( 2013-05-07 23:29:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-29 06:33:22 -0500

Seen: 692 times

Last updated: May 07 '13