Ask Your Question
1

Husky A200 gmapping transform problem [closed]

asked 2013-03-25 06:24:13 -0500

updated 2014-01-28 17:15:53 -0500

ngrennan gravatar image

Hi Again,

I am trying to use Gmapping on a Clearpath Husky A200 with a Sick LMS100 laser range finder. The problem I am running into is that there is no tf from odom to base_footprint. I tried using a static_transfor_publisher to force a connection, but I have found that I will only get the first map scan and then nothing else as it appears that gmapping updates the map based on changes in the odom->base_footprint transform. Since I was using a static transform it never changes, therefore the map never updates. According to the gmapping package page on the wiki this link is usually provided by the odometry system. Anyone know why it is not being provided in this instance or how I can fix this?

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Icehawk101
close date 2013-03-28 06:58:09

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-03-25 07:43:26 -0500

Ben_S gravatar image

As far as i can see, the clearpath_husky stack does not provide any transforms out of the box. However you can get odometry messages from the husky_bringup package on the /encoder topic. These can be used as input for robot_pose_ekf or laser_scan_matcher, which both can publish the required odom(world) -> base_link transform.

In your case the laser_scan_matcher could even be used without any odometry data from the husky plattform at all. You just need to feed your laserscans into it, set ~fixed_frame to "odom" and both ~use_imu and ~use_odom to "false". Even if this odometry is far from optimal, it should give you a starting point for the gmapping usage.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-25 06:24:13 -0500

Seen: 385 times

Last updated: Mar 25 '13