Ask Your Question
0

how to install eclipse in GROOVY

asked 2013-03-25 00:49:13 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

HI, everyone, I want to install eclipse in GROOVY(following the tutorial:http: // www. ros. org /wiki/IDEs) ,however, In the 2rd step-make eclipse-project, I always get error like:make: No rule to make target `eclipse-project'. Stop.*, I'm sure that I had set my path to the target package, so I have no idea what to do now.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2013-03-25 02:20:00 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Since groovy, with catkin workspaces, you need to call the standard cmake way of building eclipse projects.

I have added an alias in my .bashrc that says the following :

alias catkin_eclipse='catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles"'

But if you don't like aliases, you can just call :

catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles"
edit flag offensive delete link more

Comments

@Hansg91,I tried to added an alias in my .bashrc, but it seems no use, and when I use catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles" in the terminal like catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles", I just got The specified source space "/home/tishiba/src" does not exist

DavidXiong gravatar imageDavidXiong ( 2013-03-27 03:35:39 -0600 )edit

Are you using a catkin workspace? Then this should work in your root folder of that workspace. If you are using a row workspace then make eclipse-project should still work I believe.

Hansg91 gravatar imageHansg91 ( 2013-04-03 00:06:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-25 00:49:13 -0600

Seen: 586 times

Last updated: Mar 25 '13