Ask Your Question
0

edit exploration package

asked 2013-03-24 22:36:03 -0500

Xittx gravatar image

updated 2013-03-25 18:24:18 -0500

i have tried editing the exploration package but failed . these are the following commands i tried after editing.

/opt/ros/fuerte/stacks/exploration/explore$ cmake .

/opt/ros/fuerte/stacks/exploration/explore$ rosmake

/opt/ros/fuerte/stacks/exploration/explore$ make

now when i run the explore node (/opt/ros/fuerte/stacks/exploration/explore/bin$ ./explore) following error occurs

* glibc detected ./explore: corrupted double-linked list: 0x0919d538 **

i hope somebody will help. thankyou

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-24 22:44:28 -0500

updated 2013-03-25 18:22:18 -0500

You better use overlays instead of trying to change installed packages in place.

EDIT: (presuming you are on clean ROS installation)

After making overlay workspace with sandbox directory (as described above) do:

$ roscd && cd sandbox

Now you should be in ~/fuerte_workspace/sandbox or wherever you have made overlay.

Next, download exploration stack sources:

$ svn co http://svn.code.sf.net/p/bosch-ros-pkg/code/trunk/stacks/exploration

Update rosstack and rospack cache:

$ rosstack profile && rospack profile

Make sure that overlaying stack is visible to ROS:

$ roscd explore

This command should bring you to ~/fuerte_workspace/sandbox/exploration.

Now you can edit the sources.

To compile the whole stack:

$ rosmake exploration

And finally to run explore node:

$ rosrun explore explore

In general, it is not a good idea to run node executable directly. So always use rosrun.

edit flag offensive delete link more

Comments

thanks for responding Boris. i have done what you said but still having the same problem.

Xittx gravatar image Xittx  ( 2013-03-25 06:13:41 -0500 )edit

Did you add overlay after clean installation of ROS? If not, reinstall ROS and try again.

Boris gravatar image Boris  ( 2013-03-25 16:25:55 -0500 )edit

yes i remove it using this command (sudo apt-get remove ros-fuerte-*) , reinstall ROS and add overlay but still having the same problem . i,m using fuerte in 12.04

Xittx gravatar image Xittx  ( 2013-03-26 21:29:04 -0500 )edit

Could you post the changes you made to original package?

Boris gravatar image Boris  ( 2013-03-26 21:49:00 -0500 )edit

the modified stack compiled and run successfully in my friend,s laptop , may be a problem with OS. thanks for responding once again Boris. i have just printed a string in terminal just to check it

Xittx gravatar image Xittx  ( 2013-03-27 07:59:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-24 22:36:03 -0500

Seen: 172 times

Last updated: Mar 25 '13