ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Gmapping localization problem Turtlebot

asked 2013-03-22 06:39:41 -0500

CarolineQ gravatar image

updated 2013-03-29 19:10:52 -0500

bit-pirate gravatar image


I am actually experimenting the gmapping package with the Turtlebot2. To create the map I am using a Hokuyo Laser and not the Kinect.

Everything works fine at the beginning, but at one point the Turtlebot has a localization problem. It's at the right place and one second later it moves several meters away in the map in rviz. Is seems that at the same time I have this error message : [ERROR] [1363969960.064180503]: Transform from base_link to odom failed And after that the map is not precise anymore.

Do you know what I can do to solve that ? How can this transform fail ? Why ?

Thanks for help, Caroline

edit retag flag offensive close merge delete


should not! Did you experience that problems in cases other than map building?

jorge gravatar image jorge  ( 2013-03-29 01:06:22 -0500 )edit

I'm seeing the same problem. My setup is a Turtlebot1 (Create base) with Hokuyo but no Kinect, running Groovy. The symptoms I'm seeing are exactly the same on both map-building and navigating in a static map. Has anyone ever found a solution?

shiloh gravatar image shiloh  ( 2013-06-04 06:49:33 -0500 )edit

Yes, looks the same problem. I'll tackle it in shiloh's question

jorge gravatar image jorge  ( 2013-06-04 15:03:27 -0500 )edit

@jorge please post the link to that question or your answer here. Thx!

bit-pirate gravatar image bit-pirate  ( 2013-11-12 02:20:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-09-26 12:07:51 -0500

sudhanshu_mittal gravatar image

I would like to suggest a few measures which you should try out once:

  1. One of the possible problems could be stalling of CPU cycles, Firstly, check the CPU processing of your laptop while gmapping package is running on turtlebot and simultaneously observe the turtlebot movement in rviz. If you observe CPU cycle striking near 100% or if rviz hangs or goes offline for short time interval every time the turtlebot moves, then one of possible solution is to increase the parameter value of "map_update_interval" in gmapping package to around 25-30.

  2. If still the problem exists, the other solution is increase the the parameter value "maxUrange" in gmapping package according to the environment. According to my experience if your room is about 10m by 5m , then your range shoud lie around 5m atleast.

This worked out for me.

edit flag offensive delete link more

Question Tools


Asked: 2013-03-22 06:39:41 -0500

Seen: 662 times

Last updated: Sep 26 '13