Ask Your Question
1

Chaining catkin workspaces on Windows

asked 2013-03-19 09:30:10 -0500

updated 2014-01-28 17:15:47 -0500

ngrennan gravatar image

I'm been able to install ROS Groovy on Windows using the win_ros instructions (thanks to the win_ros guys for all the great work on that recently!). I'm having trouble building my own catkin packages though. How do you set up a chained catkin workspace on Windows? Is this even a feature that is supported yet?

I have my main ROS workspace in c:\win_ros\src, c:\win_ros\devel, and c:\win_ros\build. Everything built properly and the tutorial apps work. I'm trying to create a new workspace for my catkinized packages in c:\my_ws in the same way I do on Linux but without success. I've tried the following:

 c:\win_ros\devel\setup.bat
 cd\my_ws
 winros_init_workspace ./
 winros_init_build
 winros_make

Cmake is unable to find catkin and gives the following error:

CMake Error at CMakeLists.txt:47 (message):
  find_package(catkin) failed.  catkin was neither found in the workspace nor
  in the CMAKE_PREFIX_PATH.  One reason may be that no ROS setup.sh was
  sourced before.


-- Configuring incomplete, errors occurred!

Executing nmake in the root build directory

Any suggestions? Thanks.

edit retag flag offensive close merge delete

Comments

Can you post the environment before and after you run c:\win_ros\devel\setup.bat?

William gravatar imageWilliam ( 2013-03-19 10:09:01 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-19 10:36:23 -0500

Nothing like finally posting a question to make you immediately figure it out.

From looking at the scripts at: https://github.com/ros-windows/win_ros/blob/groovy-devel/rosdeps/win_python_build_tools/scripts/winros_init_build.py you can add an "underlay" when setting up the workspace:

winros_init_build -u c:/opt/ros/groovy/x86

That added a Cmake prefix variable to the config.cmake that winros_init_build makes that allowed it to find the main ros workspace and everything built correctly afterwards.

edit flag offensive delete link more
2

answered 2013-03-19 13:33:15 -0500

Daniel Stonier gravatar image

updated 2013-03-19 13:35:03 -0500

You're getting in early David. I am in the middle of updating everything and haven't made any public grunts about it yet.

Just by chance, I wrote up a wiki page on how I'm currently doing overlays in windows on the wiki yesterday. Not sure if you chanced by that yet. Still, it should have worked by repeated sourcing, so I'll check into that. Might be some errors in the setup.bat.

This is all changing quite alot still, so you might want to subscribe to a few of those win_ros/groovy pages to get notified by email when things update.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-19 09:30:10 -0500

Seen: 1,421 times

Last updated: Mar 19 '13