Ask Your Question
1

Not able to install ROSARIA on Fuerte on Ubuntu 12.04 LTS?

asked 2013-03-12 22:34:02 -0500

swagatk gravatar image

OS: Ubuntu 12.04 LTS 64 bit ROS: Fuerte

I tried following the ROSARIA tutorial on ROS Wiki.

The step where it tells you to use "roslocate info ROSARIA" does not work for me.

Then I use the command given below (on Fuerte):

$rosws set amor-ros-pkg https:_//code.google.com/p/amor-ros-pkg/ --hg
$rosws update amor-ros-pkg

It creates a package "amor-ros-pkg". But I am not able to find the package using rospack command:

$rospack find ROSARIA
[rospack] Error: stack/package ROSARIA not found

However this folder is already in the ros package path:

$echo $ROS_PACKAGE_PATH
/home/swagat/ros_workspace/amor-ros-pkg:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros

so basically I can not proceed further until I fix these problems.

edit retag flag offensive close merge delete

Comments

remove the underscore in the beginning of URL.

swagatk gravatar image swagatk  ( 2013-03-12 22:34:28 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-03-20 04:03:02 -0500

ReedHedges gravatar image

Hello,

Try specifying the fuerte branch of rosaria manually:

rosws set amor-ros-pkg https://code.google.com/p/amor-ros-pkg/ --hg -v fuerte

then use rosws update, and confirm changes and follow instructions printed to update.

edit flag offensive delete link more

Comments

This worked for me and thanks for updating the tutorial :(http://www.ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA). I am now able to build ROSARIA Package. Thanks for the help.

swagatk gravatar image swagatk  ( 2013-03-25 20:12:02 -0500 )edit
0

answered 2013-03-14 19:29:30 -0500

swagatk gravatar image

Yes, I did that too. Infact, I tried to follow the steps given in the following link (remove the underscore after http). But it did not work.

http:_//answers.ros.org/question/56360/installing-rosaria-without-roslocate-info-rosaria-instalacao-do-rosaria-sem-utilizar-o-roslocate-info-rosaria/

edit flag offensive delete link more
0

answered 2013-03-15 10:47:58 -0500

I have the same problem. $rospack find ROSARIA

it dosent find the ackage

edit flag offensive delete link more
0

answered 2013-03-13 07:33:09 -0500

damjan gravatar image

Have you done:

$rospack profile

after the rosws update?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-12 22:34:02 -0500

Seen: 1,167 times

Last updated: Mar 20 '13